Jump to content
Sign in to follow this  
You need to play a total of 20 battles to post in this section.
timmyg1004

Please fix your game!

5 comments in this topic

Recommended Posts

164
[OO7]
Beta Testers
278 posts
19,045 battles

I dont know about anyone else but I`am experiencing multiple issues with my vanilla client. #1- chat window sticks to my mouse and iam forced to restart the client #2- transaction errors during clan wars and random games #3- no post battle screens and sending me directly to port #4- UI constantly bugged I.E. sometimes closes game when clicking the chat window,slow unresponsive. I run no mods and have done a clean re install and verify my client and files constantly. So there should be no reason this game does these things. I have never once had an experience like this  with any other game i have played in the last 20 years! 

  • Cool 1

Share this post


Link to post
Share on other sites
554
[-TKS-]
[-TKS-]
Members
1,252 posts
12,243 battles

frustratingly true on all accounts. multiple crashes /bugs, and too many required client restarting to get the game to act right. in fact, im in the forum right now because I am waiting for the client to restart from a hard crash. fairly sloppy QA. 

Share this post


Link to post
Share on other sites
Guest
Guest
0 posts

agreed, client has been very buggy recently. Multiple freezes (usually on return to port after a battle), late battle results, UI (cv) not accepting certain inputs, client crashes forcing pc restart. I was beginnong to think my pc had problems, but I am kind of relieved by the news, I am not alone, and the source of the problems may be the client itself.

Share this post


Link to post
Share on other sites
50
[ASHIP]
Members
138 posts
10,669 battles

Sometimes, my game runs choppy. And I have a high end gaming laptop with a GeForce 1070 video card. Any suggestions or is it a bug in the latest upgrade?

Share this post


Link to post
Share on other sites
Members
126 posts
11,279 battles

I've been having some of the same problems, like going straight to port after a match. But my biggest problem is game is causing a hard computer lock up... And it's random as to when it will do it. Been going on now for about 3-4 weeks. At times it may go 3,4-5 days with locking up. Then like the last couple of days, I can't even play a single match before it locks up..... And to top it off, Wargaming has now put me in the penalty box and I can only play Co-Op for at least 10 matches... Freakin great when you get penalized and ban from about all type of matches because of a coding error or something on Wargaming's part.... Complete [edited] to have to serve at least a 10 match ban when I've done nothing wrong ... I'm like the OP and I'm not running any mod and never have ran any, the only time I have a computer lock-up is when I have tried play WoW over the last 3-4 weeks... Have not added any other program on my computer in that time frame other then the normal Windows 10 updates and the WoW updates.. Can't pull Critical Error Crash Report because it's a hard lock-up and I have to reboot computer.... 

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×