Jump to content
You need to play a total of 5 battles to post in this section.
LT_Rusty_SWO

Submarines are already in regular gameplay, and I killed one today.

8 comments in this topic

Recommended Posts

5,034
[ERN]
Modder, Alpha Tester, In AlfaTesters, Beta Testers
10,843 posts
4,871 battles

look like a bug to me. Or you just re loaded back into battle after being disconnected.

Share this post


Link to post
Share on other sites
1,257
[XBRTC]
Members
3,154 posts
10,011 battles
1 minute ago, MajorRenegade said:

look like a bug to me. Or you just re loaded back into battle after being disconnected.

 

I'm sure it is just a bug. I think that's actually supposed to be a Shokaku, but I didn't get the kill. My shells landed at the same time as someone else's.

Share this post


Link to post
Share on other sites
10,495
[ARGSY]
Members
18,280 posts
12,723 battles
15 minutes ago, LT_Rusty_SWO said:

Check that out.

 

image.thumb.png.af0b724cd454e2ae54d1cdbd528bb2c5.png

Unless you ran it down in HMS Dreadnought, it doesn't count.:Smile_hiding:

  • Cool 1

Share this post


Link to post
Share on other sites
91
[S0L0]
Members
304 posts
7,531 battles
1 hour ago, Ensign_Cthulhu said:

Unless you ran it down in HMS Dreadnought, it doesn't count.:Smile_hiding:

or the Olympic  :P

  • Cool 1

Share this post


Link to post
Share on other sites
1,257
[XBRTC]
Members
3,154 posts
10,011 battles
1 hour ago, steve6027 said:

its like pearl harbour, you sank a sub, no one will ever believe you.

 

Well, WARD should have gotten a screenshot after the battle. It's their own fault for not doing that.

  • Funny 2

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×