Jump to content
Randy_Mennie

Can't Login to WoWS Even Once

5 comments in this topic

Recommended Posts

Members
5 posts
52 battles

Every time I try to login into the game I get:

Error Connecting Server

Incorrect email address or password

Customer Service Center

It also has me on the WOS ASIA server when I specifically selected the NA server.  I can log in to the na.wargaming.net site with the same id and password, but not into the game.  I have reset my password etc.  etc. etc.

Yes, I have completely deleted the app from my mac and re-installed it.

I'm not sure if this is just another support site that never gets replied to by the support team and is actually just a feudal attempt to get help.  It seems that way from the posts.

Maybe they just don't want new players.

Share this post


Link to post
Share on other sites
Community Department
2,556 posts
716 battles
1 hour ago, Randy_Mennie said:

Every time I try to login into the game I get:

Error Connecting Server

Incorrect email address or password

 Customer Service Center

 It also has me on the WOS ASIA server when I specifically selected the NA server.  I can log in to the na.wargaming.net site with the same id and password, but not into the game.  I have reset my password etc.  etc. etc.

Yes, I have completely deleted the app from my mac and re-installed it.

I'm not sure if this is just another support site that never gets replied to by the support team and is actually just a feudal attempt to get help.  It seems that way from the posts.

Maybe they just don't want new players.

Did you create the account on NA server? You need to install NA client to login on NA server due to some differences in our clients on different regions.

Share this post


Link to post
Share on other sites
Members
5 posts
52 battles

Yes, I did create the account on the NA server.  I am using the worldofwarships_na.dmg installation package.  I have uninstalled and re-installed everything using this package and still end up on the Asia server.  Is there any way of changing that?  I don't mind nuking everything and starting over since I am only on Level 2.

Also, when I do get in and am in combat, after about 2-3 minutes of play the screen freezes, even thought the audio keeps playing.  I have to Force Quit and start over.

 

Thanks

Share this post


Link to post
Share on other sites
Members
5 posts
52 battles

You know what?  Forget this question.  I was able to connect to a game and play for about 2-3 minutes before it locked up and penalized me for quitting a game too early.

Now when I go to connect to a game the app simply disappears.

I haven't got time for flaky software like this.  I may go and try it on my PC but for the time being I'm uninstalling it from my Mac.

Edited by Randy_Mennie

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×