Jump to content
You need to play a total of 10 battles to post in this section.
Darkwing_x_Duck

I Lag Out Of EVERY Game

4 comments in this topic

Recommended Posts

Members
3 posts
1,887 battles

Every match that lasts longer than 5 minutes I lag completely out of. And most of the time when I click to log back in, I have to re-enter my password. It ONLY happens in World Of Warships. Doesn't happen when I play World Of Warplanes. PLEASE HELP :Smile_sad:

Share this post


Link to post
Share on other sites
1,405
[FOXEH]
[FOXEH]
Alpha Tester
6,357 posts
10,910 battles

do you have anything else working int he background? such as a web browser?:Smile_amazed: try adjusting your settings too.

  • Cool 1

Share this post


Link to post
Share on other sites
Community Department
2,335 posts
597 battles
1 hour ago, Darkwing_x_Duck said:

Every match that lasts longer than 5 minutes I lag completely out of. And most of the time when I click to log back in, I have to re-enter my password. It ONLY happens in World Of Warships. Doesn't happen when I play World Of Warplanes. PLEASE HELP :Smile_sad:

Please create WGCheck report and attach it with all info to a ticket to our support. 
If it may be a network issue please choose "extended network diagnostics" either. 
You may also try to "check and repair" your client with launcher or WGC functionality (in WGC >> game settings >> check and repair or Launcher >> settings >> support >> check and repair) before creating a report. 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×