Jump to content
djman29

Game won’t open

4 comments in this topic

Recommended Posts

Members
5 posts
238 battles

My game won’t work. I have 2 accounts, one for the American and one for the European servers. Whenever I open up the American account everything looks good, but when I click the play button nothing happens. However, when I open the European account it says that my game has been corrupted, and that I should click the repair button, but when I do nothing happens. Also, when the launcher is open it’s red on the bar at the bottom of the screen.

Share this post


Link to post
Share on other sites
Community Department
2,199 posts
542 battles
20 hours ago, djman29 said:

My game won’t work. I have 2 accounts, one for the American and one for the European servers. Whenever I open up the American account everything looks good, but when I click the play button nothing happens. However, when I open the European account it says that my game has been corrupted, and that I should click the repair button, but when I do nothing happens. Also, when the launcher is open it’s red on the bar at the bottom of the screen.

Two different accounts need to different clients on EU and NA. 
If you run WGC than you should enter Game Settings and choose "Install additional game instance" and then choose the second (EU or NA) game client to install. 
If you run Launcher than you need to install two different clients from EU and NA Portals. 

Share this post


Link to post
Share on other sites
Members
5 posts
238 battles
13 hours ago, turbo07 said:

Two different accounts need to different clients on EU and NA. 
If you run WGC than you should enter Game Settings and choose "Install additional game instance" and then choose the second (EU or NA) game client to install. 
If you run Launcher than you need to install two different clients from EU and NA Portals. 

I have both of the instances, the problem started a day or two after I added the second one

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×