Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
xXBandit1

Fps drop

6 comments in this topic

Recommended Posts

0
[STW]
Members
2 posts
6,874 battles

I have a 1080ti and experience FPS averaging around 75-80. 

Just today, I've been averaging in between 35-45. I've done all driver updates and there was no change in fps. 

Anyone else experiencing these low fps drops?

Share this post


Link to post
Share on other sites
0
[STW]
Members
2 posts
6,874 battles

When the game counts down until start. I'm running 80fps, as soon as the game starts it drops immediately.

Share this post


Link to post
Share on other sites
Community Department
2,203 posts
542 battles
14 hours ago, xXBandit1 said:

I have a 1080ti and experience FPS averaging around 75-80. 

Just today, I've been averaging in between 35-45. I've done all driver updates and there was no change in fps. 

Anyone else experiencing these low fps drops?

This issue has different reasons. There is no sense to guess the reason if you've checked game integrity and deleted mods. Also I would try to switch to DirectX11. 
If nothing helps make a ticket to support. Attache WGCheck report and description of your issue. 

Share this post


Link to post
Share on other sites
125
[OGRES]
[OGRES]
Beta Testers
504 posts
13,272 battles

Well my perspective is if it is a know issue why doesn't WG fix it then.

Share this post


Link to post
Share on other sites
17
[KSC]
Members
60 posts
6,402 battles

Been having issues recently. I am pretty much pegged at 75-77fps all game @ 4K resultion, but I'm somehow experiencing a lot of microstutter. It's like I like I lose 20-30 frames. Ping is usually in the 30s to 40s. I have a 1080ti w. Ryzen 7 1700  - there's no way it's a performance problem. 

 

I reinstalled the game. I updated drivers. I disabled background apps. I turned off things like FXAA. Nothing seems to help. 

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×