Jump to content
Sign in to follow this  
You need to play a total of 5 battles to post in this section.
iDuckman

Steam client file structure questions

6 comments in this topic

Recommended Posts

1,091
[WOLF3]
Members
5,979 posts
2,203 battles

Some questions: 

1) In the Steam client there are numbered subfolders, seemingly one per release.  These hang around.  Is it safe to delete the older ones?  They can approach 1 GB is size.

Screenshot_67.png.1df1487b7aca11698b88a2d110f7e915.png

Likely, the older, smaller ones are "stuck" because they have non-WG files in them.  (Aslain's mods)  but the larger, more recent ones have lots of WG files.

 


2)  Where are the replay files?  Supposedly I have had replays turned on since I started this account, but no replays folder or .wowsreplay files.

For that matter, where is preferences.xml?  Edit: Found it.  It's in steamapps/common/World of Warships.  No, the replay flag was not set.

 


3)  In the profile folder there is a whole mess of ub_player_error...log files, all empty.  WTH?

Screenshot_68.png.82765dfea000d878bdb5b4f142434b29.png

 


4)  Does anyone have mxstats working with a Steam client?

 

Edited by iDuckman

Share this post


Link to post
Share on other sites
282
[-WPG-]
Members
737 posts
3,145 battles

1) I have been running off of Steam since March and only have 2 numbered directories under ..\bin. One from oct5 and one from oct17. Should be easy to test if they're needed. Just move them out to a different directory and see if it's ok. You be the guinea pig though. :-). 

2). Replays should be in ..\replays directory under the main wows directory.  I have the same path as yours, so not sure why your replays is missing. Did you use the replay .exe tool or modify your preferences.xml to enable them?  I used the tool. 

Share this post


Link to post
Share on other sites
1,091
[WOLF3]
Members
5,979 posts
2,203 battles
5 minutes ago, DouglasMacAwful said:

2). Replays should be in ..\replays directory under the main wows directory.  I have the same path as yours, so not sure why your replays is missing. Did you use the replay .exe tool or modify your preferences.xml to enable them?  I used the tool. 

I used the option in the Aslain's Modpak install.  I guess it doesn't know where the preferences.xml file is on Steam.  It does say at the outset that "WoWS does not appear to be installed in this [number] folder."

I've set it manually now, so we'll see.  Shame not to have the replay history.  I also want to check whether mxstats works with a Steam client...

 

Share this post


Link to post
Share on other sites
147
Members
706 posts

you could always just delete them, then click on the WoWS properties in Steam and verify the files, and Steam will just replace any missing files, if you do it a few hours before you intend to play, then steam should have plenty of time to download the files without impinging on your play time, that assuming you have a >16mbps (>2MBps) download speed.

Share this post


Link to post
Share on other sites
1,091
[WOLF3]
Members
5,979 posts
2,203 battles

I've moved the old folders to another folder.  We'll see.  I expect it will be okay.

Also found this cute little Read_me from Aslain:

Steam users can find proper folder in this path:

C:\Program Files (x86)\Steam\steamapps\common\World of Warships\bin\[build id]\

(the build id will change every WG update)


To find current Build ID visit https://steamdb.info/app/552990/depots/
 (it's under Branches at public row)

 

I do not recommend playing WoWs using steam client because not all mods work on it.

So far, all the mods I use do work on Steam.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×