Jump to content
You need to play a total of 5 battles to post in this section.
Charlie_The_Cat

I am disguted and feel cheated by the game

57 comments in this topic

Recommended Posts

Members
43 posts
4,665 battles

This situation happens quite often but I really didn't pay attention.

Tonight, this last game was the last straw and I fired up replay to take a screenshot.

Tell me again why this Haruguo didn't even take a SINGLE torp hit, when it was clearly a kill.

jwGpqXT.jpg

  • Funny 1
  • Boring 1
  • Bad 2

Share this post


Link to post
Share on other sites
112
[-TDF-]
Beta Testers
255 posts
3,194 battles

Could you post the replay? Screenshot is not helpful but I'm betting he was going full speed and rudder turned around them all.

Share this post


Link to post
Share on other sites
135
[ODIN]
[ODIN]
Members
456 posts
13,323 battles

Also dont discount lag. Ever seen splashes land around your ship but take no damage and think "phew" only to take damage? It's just a bit of lag in the connection.

  • Cool 1

Share this post


Link to post
Share on other sites
2,412
[PNG]
Supertester, Beta Testers
5,664 posts
6,472 battles

It's traveling at full speed, so 36 knots, and likely turning into the torpedoes.

Share this post


Link to post
Share on other sites
38
[TFLT]
Members
148 posts
9,146 battles

What you see displayed on your screen isn't always what happened. Lag can make it look like torps went right through a ship when in actuality the ship passed by the spot the torps would have intersected it long before. This is quite common.

  • Cool 1

Share this post


Link to post
Share on other sites
422
[PVE]
[PVE]
Beta Testers
1,674 posts
3,824 battles

So you have the replay, but chose to screen shot it instead and used that as your undeniable proof?

  • Cool 1
  • Bad 1

Share this post


Link to post
Share on other sites
3,212
[GWG]
[GWG]
Alpha Tester, In AlfaTesters
15,635 posts
9,035 battles
57 minutes ago, Stand_Alone97 said:

Could you post the replay? Screenshot is not helpful but I'm betting he was going full speed and rudder turned around them all.

This or the torpedoes are not as close as it looks so being at full speed they missed.

Share this post


Link to post
Share on other sites
Members
362 posts
5,163 battles

The NA server has been complete garbage the last few days. Massive ping spikes, battle end result taking ages to load, sometimes not loading at all. Even if it looks like you hit something, WG's terrible servers said otherwise.

Share this post


Link to post
Share on other sites
Members
2,500 posts
5,485 battles

Drop the replay file where it says   "Drag Files here to attach or choose files"

Edited by dionkraft

Share this post


Link to post
Share on other sites
Members
1,697 posts
7,233 battles
28 minutes ago, The_Painted_Target said:

The NA server has been complete garbage the last few days. Massive ping spikes, battle end result taking ages to load, sometimes not loading at all. Even if it looks like you hit something, WG's terrible servers said otherwise.

I have zero issues with servers after I replaced my router.  Also had regular lag spikes in world of tanks as well.  Not a single issue with lag after I swapped my hardware, so NA server is not garbage I assure you.

Share this post


Link to post
Share on other sites
632
[HEROS]
Members
1,428 posts
12,023 battles

scratch previous..

deep water torp icon, previous poster is correct. If I recall the IJN deep water torps wont even prang a cruiser.. CV and BB only.  Read the fine tool tips!

 

 

Edited by TL_Warlord_Roff

Share this post


Link to post
Share on other sites
1,518
[-K-]
[-K-]
Members
3,108 posts
12,663 battles
36 minutes ago, TL_Warlord_Roff said:

scratch previous..

deep water torp icon, previous poster is correct. If I recall the IJN deep water torps wont even prang a cruiser.. CV and BB only.  Read the fine tool tips!

Shimas don't get DWT.

Most likely explanation is lag to the server. The actual ship is ahead of where you see it on the screen when this happens, which in this case cleanly dodges the torps (although barely). I believe the client-side recording will also contain this flaw.

  • Cool 1

Share this post


Link to post
Share on other sites
405
[XBRTC]
Members
1,417 posts
7,434 battles
2 hours ago, RedRushian said:

would say lag, your ping says negative 35, which for me always means a lag spike

 

That's odd. When I see a ping of negative 35 it always means that I'm watching a replay.

Share this post


Link to post
Share on other sites
3
[DERP]
Beta Testers
35 posts
3,789 battles

We all know the torpedo targeting reticle is a complete joke, mainly from the client to server difference in lag.  It's just like in WoT when you round a corner and shoot someone point blank and the shot goes 90 degrees wide or like in WoWs when you see a Colorado sail in a straight line 7km away for 5 minutes yet all your torp spread misses.  Hence why torpedo launching is pretty much just carpet bombing an area or get lucky guessing where someone will come.  The NA server performance has been poor since the patch lending even more to the client->server misses.  

Share this post


Link to post
Share on other sites
3
[-RUM-]
Beta Testers
4 posts
1,163 battles

without even looking at a replay, and as someone who has only played dds the entire time ive played the game up to tier 9 so far: you missed your torps, he turned left at full speed and pulled his keel outta the way. 

  • Cool 2

Share this post


Link to post
Share on other sites
535
[WORX]
Members
1,855 posts
12,893 battles

DDs are tight turning even at full speed, from what I can see. He was almost perpendicular to your torps ( not a good thing for you). All he as to do is swing the fantail to complately avoid all of your torp treat. was it possible ? he lived did he ? I would argue good torpedo beats award in match award.

Can any concur with the pic or do we need the replay to give it justice ? Guys ? and Ladies ?

Share this post


Link to post
Share on other sites
Members
1,156 posts
6,931 battles
50 minutes ago, LT_Rusty_SWO said:

 

That's odd. When I see a ping of negative 35 it always means that I'm watching a replay.

i usually see it right before the game kicks me out after losing connection.  i see that and i know that i am out of the battle for the next 3 min. 

 

2 hours ago, Edgecase said:

Shimas don't get DWT.

Most likely explanation is lag to the server. The actual ship is ahead of where you see it on the screen when this happens, which in this case cleanly dodges the torps (although barely). I believe the client-side recording will also contain this flaw.

yep.  should always aim slightly ahead of where you should to compensate for lag.   depending the lag you have and size of ship, you may have to aim well ahead of the enemy ship. 

Share this post


Link to post
Share on other sites
1,176
[SIM]
Members
2,537 posts
4,182 battles

He didn’t take a single hit because you missed him. Those torpedoes are clearly off target and were released too early/without proper lead, probably in the heat of the moment. It happens to a lot of players, they just don’t come to the forums to gripe about it. 

  • Cool 1

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×