Jump to content
Sign in to follow this  
You need to play a total of 5 battles to post in this section.
IronMike11B4O

Why are my guns firing?

9 comments in this topic

Recommended Posts

569
[KP]
Members
2,066 posts
18,799 battles

I think there is a bug? I noticed it awhile ago where my hand isn't on the mouse and I press W or a consumable button and my main battery guns fire. It wouldn't be a big deal except last night in the Kamikaze a ship not known for good guns I got lit up. This has happened to others in my clan as well as other random players as I have witnessed this when looking around during battle. Can this be fixed? Or is this like radar that sees through everything and we just have to deal with it?

This is not my first post about this. Still not fixed.

Share this post


Link to post
Share on other sites
Members
3,471 posts
6,176 battles

A replay sent in with a bug report (in the support forum) would probably help since the 'replay' has all of the data for the game.  I have never had it happen, so it is not widespread, which will make it exponentially harder to find a cause.  My guess is that the keyboard maybe sending out a signal that would equate to fire and WG is not going to be able to do anything about that.  You might also want to make sure that in the settings there is only one way to fire guns - via left mouse button.  Running an integrity check on the files may also help.

Share this post


Link to post
Share on other sites
151
[B2P]
Members
517 posts
13,684 battles

Are you playing on a laptop with a touchpad?  Others have noted with this setup that a stray finger or thumb on their WASD hand was bumping the touchpad and making their guns fire.  If so, disable the touchpad for the game.

  • Cool 3

Share this post


Link to post
Share on other sites
17
[BUNNY]
Members
182 posts
7,813 battles

Used to happen to me on a laptop. Now I disable the touchpad automatically on loading the game client

 

Share this post


Link to post
Share on other sites
308
[-WPG-]
Members
809 posts
3,352 battles
9 minutes ago, DreadRaybo said:

Are you playing on a laptop with a touchpad?  Others have noted with this setup that a stray finger or thumb on their WASD hand was bumping the touchpad and making their guns fire.  If so, disable the touchpad for the game.

Yeah I play on an inspirion. I wish there was some hotkey to disable the touchpad. If I realize it's on during a game, I have to tab out, go to settings, type in "touchpad", then click to disable it. Often during inoppertune times in the game. 

Share this post


Link to post
Share on other sites
122
[DANKY]
Members
503 posts
1,618 battles

I wish there was a fix for when I accidentally charge a smoke cloud expecting to duel a Benson and there's a Minotaur in there.  I tried updating my judgment to the latest version but it happened again just the other night. 

  • Funny 3

Share this post


Link to post
Share on other sites
1,231
[WOLF3]
Members
6,466 posts
2,414 battles

I haven't noticed it when doing Free Look.  But I have noticed that the middle mouse button (on most, the scroll wheel) is also a Fire button.  Since the scroll wheel is raised, it is easier to trigger accidentally.  Could that be it?

 

Share this post


Link to post
Share on other sites
605
[OPRAH]
[OPRAH]
Beta Testers
3,882 posts
12,626 battles

Disable the touch pad or adjust your mouse button sensitivity!

Share this post


Link to post
Share on other sites
Members
2,501 posts
5,489 battles

Its the touchpad thats doing it..recently I bought a Alienware m17 r4 to use along with my game pc and I noticed that WOW did shoot by itself and it was the touchpad being ON. . Luckily the laptop has a function key to turn on/off the touchpad. or T-Pad at any given time. 

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×