Jump to content
Sign in to follow this  
You need to play a total of 5 battles to post in this section.
MAJ_DUNDEE

Battle Ship misfiring turets

9 comments in this topic

Recommended Posts

15
[USCC2]
Members
21 posts
5,964 battles

Every now and again, I line up a broadside shot.....nothing in the way, open sea. Pull the trigger and it is like only one turret fired....and the other two didn't because I only see three shells going down range and it shows all three turrets reloading. Anyone else have that happen to them...

Share this post


Link to post
Share on other sites
550
[MIA]
Beta Testers, In AlfaTesters
2,314 posts
8,050 battles

you need to click twice to have your guns all fire at the same time.

Share this post


Link to post
Share on other sites
2,372
[MIA]
Supertester, Supertester
6,437 posts
7,764 battles

@MAJ_DUNDEE

Nice portrait Captain!

 

When you have a type of ammo loaded it looks like this:

abcef1b919.png

When you press "2" once it will engage a mod called "load after-firing" which looks like this:

d15d3f9eea.png

It will only switch once you double-click (full salvo) or when you fire one turret, it will reload the other shell-type.

In this picture in the spoiler, I had just full-salvo'd and it automagically loads AP after I fired HE.

Spoiler

b495a919c2.jpg

Hope that helps!

  • Cool 1

Share this post


Link to post
Share on other sites
151
[HSD]
Members
376 posts
10,034 battles

Did you have a different ammo queued up for your next shot?

Were the turrets absolutely lined up, the HUD isn't always 100% clear that the turrets are actually all fully aligned.

But yeah I have noticed when I have a different ammo queued up in say the Conq, sometimes only 1-2 turrets fire instead of all of them, I think it's either a momentary de-sync with turret alignment or the game thinking you only wanted to shoot one and not all, single click vs double click.

Share this post


Link to post
Share on other sites
15
[USCC2]
Members
21 posts
5,964 battles

I did double click.....and just one turrets worth of shells in the air...and the read out shows all the turrets fired and are reloading

Share this post


Link to post
Share on other sites
219
[VIKES]
[VIKES]
Members
560 posts
12,270 battles

That's happened to me as well, I suspect internet lag, but do not know for sure.

  • Cool 1

Share this post


Link to post
Share on other sites
55
[AK-49]
[AK-49]
Members
158 posts
2,942 battles
1 hour ago, nagasakee said:

That's happened to me as well, I suspect internet lag, but do not know for sure.

Ditto for me

Share this post


Link to post
Share on other sites
15
[USCC2]
Members
21 posts
5,964 battles

I think Kousatsu  post might have the reason why this is happening....I have to pay attention next time I am switching rounds...

Share this post


Link to post
Share on other sites
33
[MHG]
Members
63 posts
14,978 battles

My advice is to not switch rounds by queuing up the request in advance - specifically because of this feature.  Although it's possible to get the entire volley off, it's a crapshoot.  I was getting one turret off before the rest dumped their ammuntion for the reload way more often than I thought was okay.  Now I fire the entire volley and then double-press on 1 or 2 to switch.  Safer.

  • Cool 1

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×