Jump to content
KamiSamurai

Update 0.7.9 Bug Report

68 comments in this topic

Recommended Posts

217
[ZR]
Beta Testers
1,134 posts
13,038 battles

Greetings Captains!

The Update 0.7.9 is here, so please provide any bug reports you may encounter here. 

Please also check our little guide on how to report a bug here: 

Spoiler

If you're fairly certain you've encountered a bug, we'd like to encourage you to submit it to the Game Support section of the WoWS ticket queues, within a section where bugs are asked for, or to create a post within this sub-forum.

 

Remove your mods and try again before sending in a bug report as mods tend to be the culprit. 

 

I do ask that you please provide any and all information that you can when reporting an issue. 

 

Something that I have noticed that really helps in tracking this sort of thing is if you fill out the following information: 

Issue: This is where you should explain the problem that you're having.

Expected Result: Tell us what should be happening.
How to Replicate: Give us exampleson
 how to reproduce this bug.
Screenshots/Replay/Supporting Info: Screenshots and Replays go a long way, so having this ready to go will really help. 

 

Just some friendly reminders of what a bug is NOT:

An aspect of game design that you disagree with ("This ship needs to be buffed" "That ship needs to be nerfed" "The ocean is the wrong shade of blue")
Items that you feel are missing from your account (almost always this is a problem with your payment method for premium stuff or an interface confusion for the rest)
Historical Inaccuracies
Issues related to your installed mods. - Remove your mods, if you gave any, and try again before sending in a bug report as mods tend to be the culprit.
We reserve the right to add to this list :trollface :
 

Forgot to mention, Remove your mods and try again before sending in a bug report as mods tend to be the culprit. 

For each report Please make sure to attach WG Check tool report to your reports! That will help us to better understand the nature of the issue you're experiencing.

You can find the instructions on how to use that tool here: 

Spoiler

Below I have included a download link to our WG Check tool. This diagnostic tool can be used for World of Tanks, World of Warships, and World of Warplanes.

This tool can be used as a way to run a diagnostic check on your game client, check to see if you're missing any game files (it will try and repair them if possible), and to gather necessary information our support team might need to address any tech/bug related issues. 

Once you have downloaded it, open the zip file and run the WGCheck.exe. After it has launched, please select the World of Warships icon and locate its directory. The default location is **C:\Games\World_of_Warships**

- Check the box labeled, *Add game client to the firewall exceptions*.

- Check the box labeled, *Extended network diagnostics*.

- Start the integrity check by selecting the orange *Start Diagnostics* button.

Be patient, it will take some time to finish.

In many instances, this should repair or at the very least diagnose what issue you may be having. 

If it doesn't resolve your issue, then I would like to ask that you please submit a support ticket to our CS team and please send us the WGCheck log that generates after the program has completed its check.

If the file size is too large for the support system, you may have to place it within a .zip file.

Lastly, if you have any mods installed on your PC, please remove them and run the check tool again (check your game client as well to see if removing the mod helped) before sending your info to us here in support. 

If you're trying to report any technical issue, please make sure to attach WG Check report to your posts. 

  • Cool 1

Share this post


Link to post
Share on other sites
Members
1 post
1,715 battles

Issue: Occasionally I will be put into a game type I haven't selected. On two occasions I had Ranked selected and once was put into Random, the second time I was put into Arms Race. I have played other Ranked games without a problem, so it is not happening all the time, just occasionally.

Expected Result: I select Ranked as a game type and I would expect to be put into a Ranked game.
How to Replicate: Select Ranked and try to play a game. Sometimes you will get put into a different game type.
 

 

  • Cool 1

Share this post


Link to post
Share on other sites
132
[PIZZA]
[PIZZA]
Members
441 posts
4,244 battles

My game has crashed every battle I start.  It will freeze and there is a critical error pop-up.  I cannot read the error because I have to close it in order to restart the client.  I tried verify game files and updated my video drivers.  I have tried several times and I cannot play!

WoWS_report.wgc

I re-installed the entire game and it works now!

Edited by 0NutsNBolts0

Share this post


Link to post
Share on other sites
3,799
[GWG]
[GWG]
Alpha Tester, In AlfaTesters
17,484 posts
10,170 battles

I don't know if this is a bug or not but it bugs me. Simply targeting a plane turns your AA back on if you had it off and pressing P removes the target lock while turning the AA off. When I play DD's I like to have a plane that is in the area targeted but keep the AA off and only turn it on if the plane spots me.

Share this post


Link to post
Share on other sites
0
[AHOY_]
Members
3 posts
3,478 battles

The animation for the new catapult spotter on Texas doesnt work.  The plane doesnt show up on the catapult, and when you launch it it just appears flying away from the ship.

Share this post


Link to post
Share on other sites
3,320
[PVE]
Members
7,218 posts
12,439 battles

There are 2 bugs in the Arsenal with Gallant and Warspite...

  1. the details clearly state in addition to the ship and 0 pt capt you get a port slot. Neither ship is coming with a port slot.
  2. if you already own the ships your event info states you get full doubloon value of 4500 for Gallant and 6500 for Warspite. Gallant is awarding the full 4500 value but Warspite is only giving 4550 doubloons (this may be a bug tied into it being on sale in the tech tree for doubloons at 30% off in an overlap with this RN event).

I will send a ticket in to support too

Gallant:

1XT4ZdS.jpg

Warspite:

IKK0bDj.jpg

Share this post


Link to post
Share on other sites
3
[ALPHA]
Members
62 posts
7,877 battles
7 hours ago, faolan said:

None of the clan bonuses are applying (for our clan, at least).

 

shot-18_09.20_01_06.10-0539.thumb.jpg.bfd8dbea29d68921c189104dcd6c7c2d.jpgshot-18_09.20_01_04.03-0500.thumb.jpg.86788aff4a6e3f6a4d1ce76095c7f601.jpgshot-18_09.20_01_03.17-0465.thumb.jpg.b613176c76f45c9043f52d4af9706a4e.jpgshot-18_09.20_01_03.05-0797.thumb.jpg.83a07b3070d8a568f368cafdc6d265a1.jpgshot-18_09.20_01_02.35-0083.thumb.jpg.eb1723b4f25544a266558f551e9dda19.jpgshot-18_09.20_01_06.13-0439.thumb.jpg.e03e9a010b56be2162a876b507f2a065.jpg

shot-18.09.20_01.23.32-0136.jpg

shot-18.09.20_01.23.32-0136.jpg

you have to rebuild the base untill than they wont apply,this isn't a bug or an issue

 

Share this post


Link to post
Share on other sites
3,799
[GWG]
[GWG]
Alpha Tester, In AlfaTesters
17,484 posts
10,170 battles
1 hour ago, AdmiralThunder said:

There are 2 bugs in the Arsenal with Gallant and Warspite...

  1. the details clearly state in addition to the ship and 0 pt capt you get a port slot. Neither ship is coming with a port slot.
  2. if you already own the ships your event info states you get full doubloon value of 4500 for Gallant and 6500 for Warspite. Gallant is awarding the full 4500 value but Warspite is only giving 4550 doubloons (this may be a bug tied into it being on sale in the tech tree for doubloons at 30% off in an overlap with this RN event).

I will send a ticket in to support too

 

The Warspite is currently on sale.

Share this post


Link to post
Share on other sites
0
[TOG-N]
Beta Testers
9 posts
7,341 battles
2 hours ago, Cogatanu7 said:

you have to rebuild the base untill than they wont apply,this isn't a bug or an issue

 

I did, those are the new bonuses.

Share this post


Link to post
Share on other sites
Members
75 posts
11,577 battles

I cannot open any containers - it gives me transaction error & does not allow me to exit container cargo ship screen.

In the middle of a game, I was kicked off server, had to relogin

was quickly sunk when suddenly all my consumable keys would not respond,,, like T for smoke

WGCheckError.log

WoWS_report.wgc

  • Cool 1

Share this post


Link to post
Share on other sites
Members
4 posts
6,061 battles

Game Launcher will not download the update:

Speed picks up for a couple seconds, then drops to 0 kb/s for several minutes, before picking up speed again, only to drop down to 0. It is of course, mind numbingly slow. Haven't been able to play today.

I have tried:

Restarting computer, Deleting/Redownloading Launcher, Downloading other game's updates (worked fine), restarting router.

Can anyone please help me with this? It's immensely frustrating.

(FYI: i am using the Mac client)

Share this post


Link to post
Share on other sites
42
[WOLFB]
Beta Testers
103 posts
9,402 battles

Is the Ship Building Yard discount supposed to apply in addition to the current anniversary sale, or is it just whichever is greater gets applied?  For some reason I thought they stacked in the previous patch, but now they definitely don't seem to stack.  Perhaps I am mistaken.  Can anyone please clarify?

 

Update:  The article posted today (https://worldofwarships.com/en/news/development/new-clan-base/) states that only the higher of the discounts applies at any given time.

Share this post


Link to post
Share on other sites
Members
75 posts
11,577 battles
9 hours ago, teleStraightShooter said:

I cannot open any containers - it gives me transaction error & does not allow me to exit container cargo ship screen.

In the middle of a game, I was kicked off server, had to relogin

was quickly sunk when suddenly all my consumable keys would not respond,,, like T for smoke

 

 

installed Aslain's mods - all is well for now

Edited by teleStraightShooter

Share this post


Link to post
Share on other sites
14
[HBR]
[HBR]
Alpha Tester
97 posts
6,229 battles

I noticed the same thing with the base bonuses.

I rebuilt our clan base, then played a couple of battles and none of the bonuses were added after the battles.
I opened a couple of containers and the coal bonus wasn't applied.

Share this post


Link to post
Share on other sites
12
[DIEBL]
[DIEBL]
Members
30 posts
4,246 battles

The Ship Building Yard discount did not apply when I bought a re-searchable ship yesterday in credits. I did get the 3rd Anniversary discount in credits. Shouldn't have both discounts been applied?

  • Cool 1

Share this post


Link to post
Share on other sites
523
[SIMP]
Members
1,124 posts
21 hours ago, Kevin_4444 said:

The animation for the new catapult spotter on Texas doesnt work.  The plane doesnt show up on the catapult, and when you launch it it just appears flying away from the ship.

Yep. Same here. Frustrating. :(

  • Cool 1

Share this post


Link to post
Share on other sites
139
[OGRES]
[OGRES]
Beta Testers
524 posts
13,489 battles

Only receiving a 2% free xp clan bonus when it is built to 25% bonus?

Share this post


Link to post
Share on other sites
1,733
[WOLF2]
Beta Testers
4,226 posts

Completely unable to play since the update.   At first the game crashed on trying to load.  I’ve reinstalled twice.   Now it freezes up on the battle loading screen.   Really tired of this.  Wasted two nights screwing around with it.  Thinking about just finding a new game to play.

Edit: Ran the WG Check tool.  It said the files were damaged.  (How can that be on a fresh install?). Gave me the option to recover.  I did, it downloaded8/8 files then crashed.

Now my computer won’t even boot.  Probably going to have to call somebody to fix it.   Thanks WG.   I’ve spent thousands of dollars on your game, but I might be done.   I can’t afford to have a game screwing up my computer.

  • Cool 2

Share this post


Link to post
Share on other sites
1
[CFSS]
[CFSS]
Members
3 posts
1,714 battles

Locked up 3 out of 3 times tonight. 2 when starting matches and 1 when trying to retrieve a container. the 2 times were critical errors.

  • Cool 1

Share this post


Link to post
Share on other sites
410
[CVA16]
Members
2,795 posts
10,514 battles
20 hours ago, Kyloth said:

Locked up 3 out of 3 times tonight. 2 when starting matches and 1 when trying to retrieve a container. the 2 times were critical errors.

No critical errors yet but a couple of lock ups, and a lost container just now and I just started (2 games). Guess it is not just my computer.

Update: On logging back in again, I was able to successfully collect the container I was trying to collect when it crashed.

Edited by Sabot_100

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×