Jump to content
Sign in to follow this  
You need to play a total of 5 battles to post in this section.
ixnehc

Thanks WG

14 comments in this topic

Recommended Posts

16
[R-F1]
Members
19 posts
7,387 battles

I got supercontainers yesterday and today! Today's was 50 anniversary camos. Did anniversary start early just for me XD

World of Warships 9_12_2018 11_31_04 PM.png

World of Warships 9_13_2018 10_55_41 PM.png

  • Cool 1

Share this post


Link to post
Share on other sites
1,302
[PVE]
Members
4,975 posts
22,432 battles

I was actually coming on here to thank WG because I actually just got the Anniversary gifts of 75 of each draconic flag for over 15k games & the 10 WoWS 3rd anniversary camos (haven't run any T10s to see if the SCs are available yet (have been running lower tiers to grind out some lines for the upcoming discounts) but assuming they are too...the one you just got may be 1 for running a T10 battle...

…& now I'm just curious...did you just run a T10 battle before receiving that?

I actually just got a SC yesterday or the day before also...it was 15k coal which allowed me to get Salem 7k coal earlier than I though & get a 8k jump on the Yubari...that & Campbeltown are all I have left that don't require steel in the armory).

  • Cool 1

Share this post


Link to post
Share on other sites
1,225
[SYN]
Members
3,676 posts
21,113 battles

Same here thanks WG - 60 of each flag was a nice surprise,

Share this post


Link to post
Share on other sites
920
[DPG]
Members
1,767 posts
8,141 battles
16 minutes ago, monpetitloup said:

I didnt get em yet, hope i’m not alone...

Nope, not alone.

Share this post


Link to post
Share on other sites
1,302
[PVE]
Members
4,975 posts
22,432 battles
1 hour ago, Hanger_18 said:

i go the flags but not the containers

You have to run a battle in each T10 you own not just own them to get the SCs so the SCs won't just show up. I've still been working on grinding out lower tier ships (& will be as long as the ship sales are going on or until I get all the grinds done) so still haven't run any T10s yet so still can't tell you if they are active yet...but the day changes in less than an hour & 1/2 so they will definitely be active then.

Edited by IfYouSeeKhaos
  • Cool 2

Share this post


Link to post
Share on other sites
920
[DPG]
Members
1,767 posts
8,141 battles
9 minutes ago, IfYouSeeKhaos said:

You have to run a battle in each T10 you own not just own them to get the SCs so the SCs won't just show up. I've still been working on grinding out lower tier ships (& will be as long as the ship sales are going on or until I get all the grinds done) so still haven't run any T10s yet so still can't tell you if they are active yet...but the day changes in less than an hour & 1/2 so they will definitely be active then.

Not as far as I could tell after just doing a battle in the Republique.

Share this post


Link to post
Share on other sites
8,503
[INTEL]
Members
12,295 posts
34,066 battles
16 hours ago, IfYouSeeKhaos said:

You have to run a battle in each T10 you own not just own them to get the SCs so the SCs won't just show up. I've still been working on grinding out lower tier ships (& will be as long as the ship sales are going on or until I get all the grinds done) so still haven't run any T10s yet so still can't tell you if they are active yet...but the day changes in less than an hour & 1/2 so they will definitely be active then.

Day has changed, but no server update. No SCs. No 200% bonus.

Share this post


Link to post
Share on other sites
1,458
[VW]
Members
3,886 posts
18,764 battles
15 minutes ago, Amenhir said:

Not as far as I could tell after just doing a battle in the Republique.

generally should become active in about 30min at 1100 gmt, unless they go by the change for the missions which is around 1400 gmt

 

Edited by monpetitloup

Share this post


Link to post
Share on other sites
1,302
[PVE]
Members
4,975 posts
22,432 battles
1 hour ago, Amenhir said:

Not as far as I could tell after just doing a battle in the Republique.

45 minutes ago, Taichunger said:

Day has changed, but no server update. No SCs. No 200% bonus.

Still 5 more minutes for the day to change...the container reset (an hour & 15 minutes ago) is not actually the end of the day. But day change sometimes varies by 10 minutes late so give it 15 to be sure.

When the 4k free XP weekend missions show up the day has changed.

For some reason it is usually :20 after the hour...1 hour & 20 minutes after container reset...hour varying based on time zone.

 

 

Edited by IfYouSeeKhaos

Share this post


Link to post
Share on other sites
817
[KIA-A]
Beta Testers
3,380 posts
5,624 battles
8 hours ago, IfYouSeeKhaos said:

You have to run a battle in each T10 you own not just own them to get the SCs so the SCs won't just show up. I've still been working on grinding out lower tier ships (& will be as long as the ship sales are going on or until I get all the grinds done) so still haven't run any T10s yet so still can't tell you if they are active yet...but the day changes in less than an hour & 1/2 so they will definitely be active then.

I did. I'll try again in a bit.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×