Jump to content
Sign in to follow this  
You need to play a total of 5 battles to post in this section.
Woo67

The 100 MPH ship

11 comments in this topic

Recommended Posts

2
[D_INC]
[D_INC]
Members
30 posts
2,547 battles

Has anyone else had the ship in distance ( well out of range ) show up when you are zoomed in and it is going 3 times faster then it should? It don't affect game play or anything but it is funny. just wondering if it's my cheap PC. 

Share this post


Link to post
Share on other sites
791
[SF-A]
Members
2,942 posts
5,873 battles

I think that's just lag trying to readjust itself. If you don't get any info for a few seconds, graphics freeze, then race to catch up.

That or it's a Khabarovsk.

Edited by pewpewpew42
  • Funny 2

Share this post


Link to post
Share on other sites
432
[NATO]
Beta Testers
1,820 posts
5,873 battles

I get something like that when a ship explodes at the end of its HP. It suddenly shoots ahead as its explodes.....I always blame my crappy live in the bush so called "high speed" internet.

Share this post


Link to post
Share on other sites
133
[FGNE]
Members
391 posts
2,546 battles
10 minutes ago, pewpewpew42 said:

That or it's a Khabarovsk.

Or one of those new “Le Terrible”

Share this post


Link to post
Share on other sites
979
[DUDE_]
Members
3,019 posts
13,076 battles

I set up three computer screens so I can lead a Khab perfectly at 13k away.

  • Cool 2

Share this post


Link to post
Share on other sites
89
[UEFN]
Members
471 posts
12,908 battles
36 minutes ago, hipcanuck said:

I get something like that when a ship explodes at the end of its HP. It suddenly shoots ahead as its explodes.....I always blame my crappy live in the bush so called "high speed" internet.

noticed the same thing many times, whenever ship got sunk they would propelled forward like a jetski, funny as hell.  lol

Share this post


Link to post
Share on other sites
152
[B2P]
Members
522 posts
14,213 battles
25 minutes ago, APA_204 said:

I set up three computer screens so I can lead a Khab perfectly at 13k away.

But which screen do you set up as being the main one... the one on the far right or the far left?

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×