Jump to content
You need to play a total of 5 battles to post in this section.
STINKWEED_

Bonus Premium Day and battles are not getting recorded. Now what?

7 comments in this topic

Recommended Posts

Members
1,552 posts
9,841 battles

Well, I logged in and I got my premium day. Nothing to celebrate because all my battles are not getting recorded. In fact, twice after battle it went straight to the port and the game froze on me. I had to restart the game.

I can't play until it's fixed and by then my Premium Day would have expired. Can we have the Prem day re-issued after this is fixed?  

Share this post


Link to post
Share on other sites
Beta Testers
167 posts
989 battles

I hope so too!  I lost 3 sets of consumables.  Consumables cost RL cash.  We will need reimbursement for this.

Edited by ph3l0n

Share this post


Link to post
Share on other sites
175
[SIDE]
Members
718 posts
3,160 battles

I'm gonna wait until they fix it. But a lot of people are posting in the Reporting bugs.

Share this post


Link to post
Share on other sites
105
[_AAM_]
Alpha Tester
456 posts
5,931 battles

I've already sent my ticket, and Femmenly has noted that WG is on it.  Hopefully we'll know something in short order.

Share this post


Link to post
Share on other sites
318
[SYJ]
[SYJ]
Members
917 posts
2,119 battles
8 minutes ago, ph3l0n said:

I hope so too!  I lost 3 sets of consumables.  Consumables cost RL cash.  We will need reimbursement for this.

Wait what

 

*see a 48 downvotes*

 

Oh

Share this post


Link to post
Share on other sites
1,391
[O_O]
Members
4,338 posts
9,314 battles
21 minutes ago, ph3l0n said:

I hope so too!  I lost 3 sets of consumables.  Consumables cost RL cash.  We will need reimbursement for this.

I hadn't heard about this issue.  Since I got my 24 hr premium time, I loaded up with Gamescom 2018 camo, Hydra, Dragon, Ouroboros, and Basilisk flags.  Played a great game (141k damage)...and no results.  Interestingly, my Hindy is now back in port with the camo and flags still on them (auto resupply disabled).  It's as if the game never happened.  Pity.  But, my premium time counter still works!  :Smile-angry:

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×