Jump to content
You need to play a total of 5 battles to post in this section.
tm63au

Is any one else not getting there free premium 1 day

51 comments in this topic

Recommended Posts

528
[POP]
Members
1,183 posts
15,570 battles

HI

 Am reading the post regarding the 1day of free premium time wrong because as I read it you had to have log on to either the website, the forum page or the game on Saturday which I was on all the 3 counts then go to the post and click on to the link and see if you were eligible to get this free day of premium on Monday .

Well it does not seem to be working for me and I know that I was log in all the time.  

I will send a ticket into support but just wanted to know if anyone else has had any trouble.

regards    

Edited by tm63au
  • Cool 2

Share this post


Link to post
Share on other sites
139
[FOG]
Members
378 posts
5,115 battles

I have not gotten the premium time either nor two additional containers that I should have received.

Share this post


Link to post
Share on other sites
528
[POP]
Members
1,183 posts
15,570 battles
8 minutes ago, DJC_499 said:

I have not gotten the premium time either nor two additional containers that I should have received.

Well least I'm not the only one having problems not that it helps you much either, strange happenings at WOWS 

  • Funny 1

Share this post


Link to post
Share on other sites
Members
3,685 posts
6,387 battles

What post?  I have been on all weekend and I have never seen a post about getting a day of premium...

Share this post


Link to post
Share on other sites
528
[POP]
Members
1,183 posts
15,570 battles
2 minutes ago, UltimateNewbie said:

Do you mean the free day of premium from hitting rank 12 or whatever it is?

 

Share this post


Link to post
Share on other sites
387
[PVE]
Members
1,985 posts
18,424 battles
1 hour ago, tm63au said:

HI

 Am reading the post regarding the 1day of free premium time wrong because as I read it you had to have log on to either the website, the forum page or the game on Saturday which I was on all the 3 counts then go to the post and click on to the link and see if you were eligible to get this free day of premium on Monday .

Well it does not seem to be working for me and I know that I was log in all the time.  

I will send a ticket into support but just wanted to know if anyone else has had any trouble.

regards    

The post right underneath yours is about "portal maintenance" (which is occurring right now & may continue for another hour).

I also didn't get it but just tried again from your link & got a notice that the link is under maintenance right now...assuming it is probably in regards to this & (hopefully) will be resolved after the maintenance.

Share this post


Link to post
Share on other sites
528
[POP]
Members
1,183 posts
15,570 battles
6 minutes ago, landcollector said:

I've had the same issue, and I played games on Friday  (have the screen shots to prove it too).

The main website is down at the moment but I went to the link in that post a number of times and hit on it which it intern told no bonus day more or less, the things is I play every day and  I am logged into both the forum and website always.

 sent a ticket but wont know anything till its back up and also its very early in the morning so it will be a while.

cheers  

Share this post


Link to post
Share on other sites
528
[POP]
Members
1,183 posts
15,570 battles
1 minute ago, IfYouSeeKhaos said:

The post right underneath yours is about "portal maintenance" (which is occurring right now & may continue for another hour).

I also didn't get it but just tried again from your link & got a notice that the link is under maintenance right now...assuming it is probably in regards to this & (hopefully) will be resolved after the maintenance.

Actually I tried that link a number of times before the website went down for maintenance it just told me there was no bonuses available, and I know that I was eligible as I was log in to both forum and website and game all over the weekend which is all you had to do.

So either the link was wrong and there fixing it now hence portal maintenance time will tell .

cheers    

Share this post


Link to post
Share on other sites
387
[PVE]
Members
1,985 posts
18,424 battles
Just now, tm63au said:

the link was wrong and there fixing it now

^^^that's what I was thinking...I tried it earlier (when you posted about it) also & realized I still had my PT bonuses to collect but the free day of premium wasn't available.

Share this post


Link to post
Share on other sites
519
[LOU1]
Members
3,154 posts
8,390 battles

I did not get my two containers (for buying ten) yet, either.  Must be the backlog from so much manually posting of rewards.  Both the Pirate rewards and the Anniversary collection have to be manually posted.  The unplanned website maintenance probably hasn't helped, either.

Edited by ExploratorOne

Share this post


Link to post
Share on other sites
649
[RKLES]
[RKLES]
Beta Testers, In AlfaTesters
3,563 posts
12,200 battles

I did not get free day nor the free containers.

Share this post


Link to post
Share on other sites
721
[SKDSH]
[SKDSH]
Beta Testers, In AlfaTesters
4,001 posts
10,267 battles

 Very interesting that the post about Portal Maintenance has disappeared from the Important posts area .

:Smile_honoring:

Share this post


Link to post
Share on other sites
1,308
Members
4,113 posts
8,680 battles
4 hours ago, tm63au said:

HI

 Am reading the post regarding the 1day of free premium time wrong because as I read it you had to have log on to either the website, the forum page or the game on Saturday which I was on all the 3 counts then go to the post and click on to the link and see if you were eligible to get this free day of premium on Monday .

Well it does not seem to be working for me and I know that I was log in all the time.  

I will send a ticket into support but just wanted to know if anyone else has had any trouble.

regards    

Well the Site/Portal is back-up, and I still cannot get anything. When I click the link given, I get the old " There are no bonuses available at this time. " message.

  • Cool 1

Share this post


Link to post
Share on other sites
177
[BRZKR]
[BRZKR]
Members
431 posts
4 hours ago, tm63au said:

HI

 Am reading the post regarding the 1day of free premium time wrong because as I read it you had to have log on to either the website, the forum page or the game on Saturday which I was on all the 3 counts then go to the post and click on to the link and see if you were eligible to get this free day of premium on Monday .

Well it does not seem to be working for me and I know that I was log in all the time.  

I will send a ticket into support but just wanted to know if anyone else has had any trouble.

regards    

I am in the same group. I wonder why the premium day is not showing up. I logged in on Friday as well.

Edited by Leopard_IX

Share this post


Link to post
Share on other sites
1,308
Members
4,113 posts
8,680 battles
10 minutes ago, LancerUlysses said:

Nope, nothing for me, I have 4 boxes supposed to be coming, plus the premium day. 

 

17 minutes ago, Leopard_IX said:

I am in the same group. I wonder why the premium day is not showing up. I logged in on Friday as well.

@Femennenly

Can you or anyone else help us out, please?

  • Cool 1

Share this post


Link to post
Share on other sites
721
[SKDSH]
[SKDSH]
Beta Testers, In AlfaTesters
4,001 posts
10,267 battles
26 minutes ago, Chaos_EN2 said:

Well the Site/Portal is back-up, and I still cannot get anything. When I click the link given, I get the old " There are no bonuses available at this time. " message.

 

23 minutes ago, Leopard_IX said:

I am in the same group. I wonder why the premium day is not showing up. I logged in on Friday as well.

 

5 minutes ago, Chaos_EN2 said:

 

@Femennenly

Can you or anyone else help us out, please?

 Yep same for me when I just checked ( except I am only supposed to be getting 1 container ) .

:Smile_honoring: 

Edit : And also aren't we supposed to get the Pirate Event swag today ( I ; barely lol ; managed to bag 1 pirate and 1 pirate captain ) .

Share this post


Link to post
Share on other sites
721
[SKDSH]
[SKDSH]
Beta Testers, In AlfaTesters
4,001 posts
10,267 battles

 I have been in a PM exchange with @Femennenly and she has let me know that the Dev's are aware of the link not working for the premium day and are working on that now . So to quote " hang tight " . 

 Sheesh what a mess this has turned into ; lol .

:Smile_honoring:

Share this post


Link to post
Share on other sites
933
[WGA]
Administrator, Community Department, WG Staff, Retired Community Contributors
324 posts
12,604 battles

Heyo Captains,

Apologies again, we're working on the link not working and we will update you as soon as we know more.

Fem, 

  • Cool 3

Share this post


Link to post
Share on other sites
311
[WOLF1]
Members
2,203 posts
1 minute ago, Femennenly said:

Captains,

Apologies again, we're working on the link not working and we will update you as soon as we know more.

Fem, 

thanks, hope it get fixed soon

Share this post


Link to post
Share on other sites
1,308
Members
4,113 posts
8,680 battles
6 minutes ago, Femennenly said:

Heyo Captains,

Apologies again, we're working on the link not working and we will update you as soon as we know more.

Fem, 

Thank you Dear Lady:Smile_honoring:

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×