Jump to content
Sign in to follow this  
Wombatmetal

new Game Center doesn't work

9 comments in this topic

Recommended Posts

1,027
[NMKJT]
Members
3,701 posts

I have it installed and running, and it has my userid and password correct, my account name is displayed, but it doesn't pass them correctly to the game clients. They get a password error and I have to retype it in and hit enter. If it doesn't log me into the game, what's the point?

It also uses more CPU with a game client running than when it is "sleeping" in the system tray. 

Share this post


Link to post
Share on other sites
Members
67 posts
3,002 battles

In my experience the WGC is the main cause for the lag spikes I have been observing in both ships and tanks.

I told WGC a long time ago and I got the usual robotic responses so I gave up.

  • Cool 1

Share this post


Link to post
Share on other sites
0
[-BTP-]
Members
1 post
2,255 battles

Hi All,

I cannot get the game to start. I have clicked on the WGA icon on my desk top , the little windows wheel spins for about a second or two and then disappears. I was on last night after the latest up date to the new wargaming system.  Now nothing seems to work.  Anyone have a solution?

baron

Share this post


Link to post
Share on other sites
Beta Testers
1,714 posts
3,833 battles
1 hour ago, wkcw1 said:

In my experience the WGC is the main cause for the lag spikes I have been observing in both ships and tanks.

I told WGC a long time ago and I got the usual robotic responses so I gave up.

The same in my experience as well. It seems that “new and improved” is still buggy and laggy. I am going to steam I am hopeful that more speak out in support of either keeping the current launcher or a migration to steam.

Share this post


Link to post
Share on other sites
Beta Testers
1,714 posts
3,833 battles
1 hour ago, Wombatmetal said:

I have it installed and running, and it has my userid and password correct, my account name is displayed, but it doesn't pass them correctly to the game clients. They get a password error and I have to retype it in and hit enter. If it doesn't log me into the game, what's the point?

It also uses more CPU with a game client running than when it is "sleeping" in the system tray. 

If you want it gone once your tired of the same issues a lot of us had. Uninstall each game one by one and then uninstall the Wgc. It is hard to get rid of it you’ll thank me later. Keep task manger open to kill the Wgc non client tasks. Long term solution rename the steam kit code to something else in the steam wows game files Ichase has a video on it.

Share this post


Link to post
Share on other sites
885
[POP]
Members
1,548 posts
17,395 battles

WGC working as intended  comrade NOT

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×