Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
Izgoy0899

Clitch that is making the game unplayable....stops taking my keyboard commands

16 comments in this topic

Recommended Posts

Members
28 posts
1,415 battles

I don't know why, but there is some bug that is causing the game to stop taking my keyboard commands.  Like I mean everything is working, then suddenly I can't do anything.  Hit WASD and nothing, hit 123, and nothing the game just refuses to accept commands from the keyboard.  I just had a game in the Leningrad where all I could do is aim and shoot the guns.  I couldn't turn and maneuver, I couln't switch shells or torps, and I couldn't even get the damage control to work when on fire.  Just burn in a straight line, shooting guns, into the path of torps fired at me.  This is the only game that has this issue, and it is the same on my SEA WoWs account.  I have played MANY games of WoT for the T-34 Shielded marathon without any issues in keyboard responsiveness.  Fallout 4 has given me no problems as well, and obviously I can type fine here.  The problem is in World of Warships, and I literally cannot play the game when it hits. 

Edited by medoyehd

Share this post


Link to post
Share on other sites
28
[ARP]
Members
63 posts
1,677 battles

Without any system info. provided, it will be quite hard to solve your issue. 

What windows are you running?

Single screen or multiple screens set up?

What keyboard are you using?

Are you able to alt+tab out of the game when having the issue?

 

 

Share this post


Link to post
Share on other sites
Members
28 posts
1,415 battles
13 minutes ago, Spacey_ said:

Without any system info. provided, it will be quite hard to solve your issue. 

What windows are you running?

Single screen or multiple screens set up?

What keyboard are you using?

Are you able to alt+tab out of the game when having the issue?

 

 

Running W7 64bit

One monitor screen

Standard ASUS keyboard, PC is ASUS. 

I was able to esc out normally that worked also.  Only thing that didn't work were the direction keys (WASD), the #keys (1-3), and the R that I hit in game.  The esc did work. 

Problem first started a couple updates ago.  Before that everything did work fine. 

Edited by medoyehd

Share this post


Link to post
Share on other sites
28
[ARP]
Members
63 posts
1,677 battles

And the issue is instantly when you enter a game or at random times?

Create a backup from your preferences.xml file from your world of warships folder (just copy the file somewhere) and then delete the preferences.xml from your world of warships folder.  ( #:\World_of_Warships )

When you start the game again it will create a new preferences.xml file. 

Give it a try and see if the issue is resolved or not.

 

  • Cool 1

Share this post


Link to post
Share on other sites
Members
28 posts
1,415 battles

It is random.  I played a game in the St Louis without issues, but happened after a minute playing the Leningrad.  I'll try that and see what happens after a few games. 

 

Thanks so far for your help.  :cap_like:

Share this post


Link to post
Share on other sites
Members
28 posts
1,415 battles

No that did not help.  Everything was good for a while, (Albany, Smith, Tachibana, Fuijin).  5th game was in the Leningrad and problem came back after a minute into the game I lost all control and game was not taking keyboard commands for movement, consumables, or ammo change.   6th game in the Graf Spee, again at first everything was ok, but in the first minute again, same issue.   I even went into my settings, since again the esc works, and defaulted my controls to see if that would sort it out but again no change as the game was not accepting keyboard commands for movement, consumables, and ammo change. 

 

My chat as well is only typing in Russian Cyrillic.  My PC is set for English. 

Edited by medoyehd

Share this post


Link to post
Share on other sites
263
[NOBS]
Members
533 posts
5,877 battles

You running a mod pack? It will do funny things sometimes. 

Share this post


Link to post
Share on other sites
Beta Testers
1,143 posts
3,273 battles

Check your settings for sticky keys or filter keys. In the "Ease of Access" area. 

On occasion I've activated that function while playing other games and noticed my keyboard all of a sudden not working. 

Telltale sign is that short presses will not type anything whereas an extended key press will. 

Share this post


Link to post
Share on other sites
Members
28 posts
1,415 battles
1 hour ago, Capt_h2o said:

You running a mod pack? It will do funny things sometimes. 

No mod packs as I play the game vanilla. 

56 minutes ago, Ivlerlin said:

Check your settings for sticky keys or filter keys. In the "Ease of Access" area. 

On occasion I've activated that function while playing other games and noticed my keyboard all of a sudden not working. 

Telltale sign is that short presses will not type anything whereas an extended key press will. 

No everything else works ok, and I can type here and everywhere else fine without any issues. 

46 minutes ago, Raven114 said:

try a different keyboard.

This is the only game that has a problem.  I've been playing WoT in the T-34 Shielded marathon since the 2nd day, couple hundred games total without issues.  Chat there works as well.  Plus no issues repeating in War Thunder when I am there, and no issues in Fallout 4.  Only World of Warships has this issue. 

Share this post


Link to post
Share on other sites
1
[D-H-O]
Members
4 posts
1,825 battles

Not sure if this is much help.  I have this happen occasionally when I set the game to "Windowed" instead of "Full screen" in the settings.  What I found is either A) I get a Windows notification which takes focus off the game, or B) I hit a key (Windows key) or combination that takes the focus away from the game.  In either of those cases, I have to hit Ctrl-tab to re-focus back to the game.  Hope that helps.

Share this post


Link to post
Share on other sites
Members
28 posts
1,415 battles

Nice to know I'm not the only one with this issue, though for me the problem first started a few months ago after the patch then. Only difference is that I can hit "esc" to get out and F(unction) Keys seemed to still be working.  Again only movement keys (WASD), Consumable keys, and ammo selection # keys stop working.  My chat also types in Russian Cyrillic even though mt PC is set to English. 

 
No I'm not intentionally typing in Russian.
 
2jb3ay8.jpg
20tjyau.jpg

 

Edited by medoyehd

Share this post


Link to post
Share on other sites
Members
28 posts
1,415 battles
2 hours ago, krazykarr5 said:

Not sure if this is much help.  I have this happen occasionally when I set the game to "Windowed" instead of "Full screen" in the settings.  What I found is either A) I get a Windows notification which takes focus off the game, or B) I hit a key (Windows key) or combination that takes the focus away from the game.  In either of those cases, I have to hit Ctrl-tab to re-focus back to the game.  Hope that helps.

I've been playing the game in full screen when it happens though and not windowed.  I'll still try the idea you gave though next I test it and see if it helps. 

  • Cool 1

Share this post


Link to post
Share on other sites
28
[ARP]
Members
63 posts
1,677 battles
10 hours ago, medoyehd said:

My chat as well is only typing in Russian Cyrillic.  My PC is set for English. 

That's your issue. Your keyboard layout is probably switching keyboard layout/settings mid game. ( The hotkey for that is LEFT ALT+SHIFT, so you might have been pressing those keys in-game without knowing it)

Got to the windows run window and type intl.cpl

In that window click on the underlined Language Preferences

Now make sure you remove/delete all the languages/layouts you don't need (you will basically need to remove everything except English United States or the layout you are using)

Give it a try, I believe that is causing your issue.

You can also disable the hotkey binding using method showed below.

 

Edited by Spacey_

Share this post


Link to post
Share on other sites
Members
28 posts
1,415 battles
6 hours ago, Spacey_ said:

That's your issue. Your keyboard layout is probably switching keyboard layout/settings mid game. ( The hotkey for that is LEFT ALT+SHIFT, so you might have been pressing those keys in-game without knowing it)

Got to the windows run window and type intl.cpl

In that window click on the underlined Language Preferences

Now make sure you remove/delete all the languages/layouts you don't need (you will basically need to remove everything except English United States or the layout you are using)

Give it a try, I believe that is causing your issue.

You can also disable the hotkey binding using method showed below.

 

That could very well be the problem since I have free look mapped to my left shift key, as I want my mouse set up the same as WoT for muscle memory, and since WG seems to have removed the option to set it so you could see player names on ships always in game I have been hitting left alt for that.   I'll remap free look to another key and run some tests. 

Edited by medoyehd

Share this post


Link to post
Share on other sites
Members
28 posts
1,415 battles

That seems to have solved the problem, turning on the alt battle interface and not hitting alt for it.  Thanks as I didn't even think of that. 

 

Thanks all for your help in this.  :cap_like:

Edited by medoyehd
  • Cool 1

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×