Jump to content
Xanture

Holy UI Lag batman

3 comments in this topic

Recommended Posts

6
[NOODL]
Beta Testers
17 posts
3,677 battles

Wow, this last patch really increased the lag in the UI. I think restarting the client after every couple of games helped, but it also could be a placebo effect.

Wargaming, all the cool stuff you do for this game is diminished when it takes forever to do things like show different stats screens after a battle, exiting a battle, switching ships or adding flags. It is not acceptable for an application running on modern hardware to behave this way.

Share this post


Link to post
Share on other sites
697
[5D5]
Members
2,295 posts
14,422 battles

No one in my clan has reported issues and a lot are on due to clan battles tonight.

Share this post


Link to post
Share on other sites
97
[FAILD]
Members
427 posts
1,608 battles
50 minutes ago, Xanture said:

Wow, this last patch really increased the lag in the UI. I think restarting the client after every couple of games helped, but it also could be a placebo effect.

Wargaming, all the cool stuff you do for this game is diminished when it takes forever to do things like show different stats screens after a battle, exiting a battle, switching ships or adding flags. It is not acceptable for an application running on modern hardware to behave this way.

I havent had any issues and im running a sub par machine. Even the ping rate was normal. 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×