Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
AdmiralThunder

Slow and sluggish ship speeds/manuvering

3 comments in this topic

Recommended Posts

2,375
[PVE]
[PVE]
Members
5,875 posts
10,655 battles

So I asked in the general forums if anyone had experienced this issue (see link below) and quite a few report seeing the same thing. Could be all in our minds but I really don't think so. Lately (the last 2 patches at least maybe/probably longer) the ships just seem to travel slower across the map than they used to and they maneuver quite sluggishly compared to what I remember.  It isn't a FPS, PING, or lag issue either as those are fine. Plain and simple the ships just seem to be taking 2-3X's longer to travel the same distance on the map now.

A full WOT Cruiser going 32-33 knots + feels almost like you are in the NY @ 21knots the way it seems to slowly creep across the map. God help you if you are actually in the NY or some other 20-21 knot ship. UGH! :Smile_facepalm: It has gone from something I noticed and was like what is going on with the game today to something I notice every game now and that has become a major annoyance. It just takes forever to get anywhere on a map now even in fast ships like DD's. And the ships seem to maneuver like pregnant whales as well. Some people have reported (see link) a problem that arrives and/or worsens the more they play. For me it seems to be there from game one.

I don't know why this is happening and if it is intended or not? It might even be something that is an unintended consequence of a tweak to do/fix something else (like that whole BB citadel palooza mess a while back). Again, it could be all in my head, and the head of the others, but figured I would post this in the hope WG will at least look into it. Sitting there and waiting and waiting and waiting for your ship to get from spot A to B on the map, and trying to WASD with a drunk sea turtle,  gets so annoying.

Hopefully this is a bug and can be fixed.

Thank you for your time and for looking into it.

 

Edited by AdmiralThunder
  • Cool 1

Share this post


Link to post
Share on other sites
976
Members
4,561 posts
6,492 battles

I noticed this yesterday playing Scharnhorst in random.  Thought it might just be in my mind....dunno. Maybe just a one time thing.  She seemed to be moving so slooooow and it was noticeable.  Played her in co-op also but saw no problem.  May play tonight and see if this is still an issue. FPS was fine and there was no problem with that. 

Share this post


Link to post
Share on other sites
503
[LOU1]
Members
3,052 posts
8,140 battles

It almost seems like you are asking Support, and I would assume they read the Forum titled "Support."  As a side not, I hope you also submitted a ticket about this so that they have to officially respond to it.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×