Jump to content
You need to play a total of 5 battles to post in this section.

7 comments in this topic

Recommended Posts

517
[POP]
Members
1,166 posts
15,108 battles

In  a game just now in my Kamikaze k  in the 3 minutes of game trying to sink enemy  BB in our cap, the match going down to the wire and lag hits its so bad it bumps me out of game, try logging back its as slow as a wet week then finally get back it takes another minute to actually get into game, finally get in only see that I'm dead and we lose. 

Seriously not happy :Smile-angry: 

  • Cool 1

Share this post


Link to post
Share on other sites
606
[OPRAH]
[OPRAH]
Beta Testers
3,891 posts
12,629 battles

@tm63au Probably right about the time they reset the servers!

Share this post


Link to post
Share on other sites
Guest
Guest
0 posts

Sorry but I sank you while you just sat there.  The only ones left was you (your team) and me with a BB(my team) in your cap.  I was the ARP Cruiser.

Share this post


Link to post
Share on other sites
517
[POP]
Members
1,166 posts
15,108 battles
4 minutes ago, Minah_Bang said:

Sorry but I sank you while you just sat there.  The only ones left was you (your team) and me with a BB(my team) in your cap.  I was the ARP Cruiser.

All's fare in love and war as they say, such is life I don't know if I could have got you both in the time left but who knows stranger things have happen just wish I could actually fought it out to last second.

Well played your team as for ours we blew the chance to win most of our players decided to stay on the opposite side your team was pushing, then when they did move it was 1 at a time and got destroyed piecemeal from focus fire.

cheers     

Share this post


Link to post
Share on other sites
267
[NOBS]
Members
547 posts
5,936 battles

I had the game lag and drop 3 times on Saturday. Wasn't on my end, then again last night had a mate in my div lag and drop, but we did lose discord. Felt like a glitch on WG's end. 

Share this post


Link to post
Share on other sites
233
[TBOW]
Members
1,253 posts
10,709 battles

Yeah got dumped out by the server last night.  A few us after play clan battles decided to do an op around 10:30pm eastern and it dumped us all out right as the OP was loading.  Couldn't get back in when we restarted the game.

Share this post


Link to post
Share on other sites
599
[ARRGG]
Members
4,732 posts
7,572 battles

My game crashed 4 times on Saturday, I finally gave up playing 

started with not being able to turn then  boat would stop and the water would appear to froth around the ship with no forward movement, then the ship like it was remembering my inputs would race ahead at about 200 miles an hour for 1 k or so not sure what others could see of my crazy fast movement

also a lot of times you went to fire your guns and nothing would happen then about 10 seconds later guns would fire obviously missing the target,, this happened last week also but then resumed to normal or near normal because there has been frequently a millisecond delay in either turning ship or shooting since last update that has put my game play off

am also booted from game numerous times sometimes getting back in sometimes not

Edited by HMCS_Devilfish

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×