Jump to content
Sign in to follow this  
You need to play a total of 5 battles to post in this section.
TL_Warlord_Roff

in 10 hours my rent a shimmy goes away and...

15 comments in this topic

Recommended Posts

632
[HEROS]
Members
1,430 posts
12,053 battles

I'd really like it this time if the premium engine boost module/upgrade does NOT disappear this time..

If it does it'll be the third time I've lost a high end special upgrade off a rental/loaner ship and it's just a bit annoying.

I'd demount it now with doubloons if I had them but I don't so let us see if this idiot bug happens again.. this time It'll be documented.

Still unhappy that I lost a bunch of coal that I should have gotten from when I was in STW-A.... Never got a reply from anyone on that.

Share this post


Link to post
Share on other sites
22,908
[HINON]
Supertester
19,236 posts
12,772 battles

Take a screenshot of the supermod fitted and keep it on hand, then open a ticket if it does disappear.

  • Cool 4

Share this post


Link to post
Share on other sites
503
[LOU1]
Members
3,052 posts
8,140 battles

If you lost equipment in the past, I hope you submitted a Support Ticket.  Equipment, Commanders, and Consumables are returned to your inventory when the rental period ends.  While a screenshot may end up being required, WG has a record of your acquisitions and sales, so you may still be able to make a case for a past loss.

On the lost coal Support Ticket: did they just close it without an answer?  In that case, you should reopen it.  I also just reread your original post and am wondering what was said on the Support Tickets from the previous losses.  Support Tickets are really the ONLY way to get a response or help from WG.  If Support was unresponsive, you can always message someone like @Radar_X.

Edited by ExploratorOne

Share this post


Link to post
Share on other sites
503
[LOU1]
Members
3,052 posts
8,140 battles

Was just checking again and I don't see an announcement for a patch dropping tomorrow morning.  Usually the rentals remain until the next patch, why are you losing the ship in 10 hours?  Disclaimer: I haven't started playing Clan Battles, so I may be missing some important details.

Share this post


Link to post
Share on other sites
1,150
[ARGSY]
Beta Testers, In AlfaTesters
5,178 posts
18,916 battles
6 minutes ago, ExploratorOne said:

Was just checking again and I don't see an announcement for a patch dropping tomorrow morning.  Usually the rentals remain until the next patch, why are you losing the ship in 10 hours?  Disclaimer: I haven't started playing Clan Battles, so I may be missing some important details.

Clan battle season ends. There is no patch needed.

Share this post


Link to post
Share on other sites
198
[STW]
Members
658 posts
4,415 battles
18 minutes ago, Erebthoron said:

Clan battle season ends. There is no patch needed.

Clan battles goes until August 19th.  They rotate the rental ships out for different ships on an interval, or at least that's how I remember them doing it last season.   What that time interval is, I can't remember.

Edited by Deviathan

Share this post


Link to post
Share on other sites
4,804
[SALVO]
Members
17,080 posts
17,754 battles
2 hours ago, TL_Warlord_Roff said:

I'd really like it this time if the premium engine boost module/upgrade does NOT disappear this time..

If it does it'll be the third time I've lost a high end special upgrade off a rental/loaner ship and it's just a bit annoying.

I'd demount it now with doubloons if I had them but I don't so let us see if this idiot bug happens again.. this time It'll be documented.

Still unhappy that I lost a bunch of coal that I should have gotten from when I was in STW-A.... Never got a reply from anyone on that.

Or you could just buy a small amount of doubloons and demount the module.

Share this post


Link to post
Share on other sites
472
[QNA]
[QNA]
Members
1,838 posts
5,881 battles
1 minute ago, Crucis said:

Or you could just buy a small amount of doubloons and demount the module.

Or only place Special Upgrades on only specific ships.

Share this post


Link to post
Share on other sites
Alpha Tester
1,275 posts
5,789 battles
2 hours ago, TL_Warlord_Roff said:

I'd really like it this time if the premium engine boost module/upgrade does NOT disappear this time..

If it does it'll be the third time I've lost a high end special upgrade off a rental/loaner ship and it's just a bit annoying.

I'd demount it now with doubloons if I had them but I don't so let us see if this idiot bug happens again.. this time It'll be documented.

Still unhappy that I lost a bunch of coal that I should have gotten from when I was in STW-A.... Never got a reply from anyone on that.

i love my shima and her 20km torps or more like 12km type are great.

Share this post


Link to post
Share on other sites
503
[LOU1]
Members
3,052 posts
8,140 battles
2 hours ago, Erebthoron said:

Clan battle season ends. There is no patch needed.

Ah.  I thought it was referring to the rental ship swap that has happened in the past.

Edited by ExploratorOne

Share this post


Link to post
Share on other sites
503
[LOU1]
Members
3,052 posts
8,140 battles
1 hour ago, _Lord_Scott_ said:

I count it lost Forever, A hopeless cause.

CS is very Spotty at best.

Guess I have been lucky.  I would still contact contact someone on the WG staff like @Gneisenau013.

Share this post


Link to post
Share on other sites
1,119
[WGA]
Administrator, Developers
900 posts
5,964 battles
14 hours ago, ExploratorOne said:

Guess I have been lucky.  I would still contact contact someone on the WG staff like @Gneisenau013.

Send me a PM and let me know what's happening.

#anchorsaweigh

Share this post


Link to post
Share on other sites
632
[HEROS]
Members
1,430 posts
12,053 battles

Well, 

 

*massive sigh of relief*

They didn't disappear this time.. In inventory right where they are supposed to be.

All good, no report...

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×