Jump to content
Sign in to follow this  
You need to play a total of 5 battles to post in this section.
scotty_geturown

New upgrade for the Shima

7 comments in this topic

Recommended Posts

10
[SFBBW]
Members
42 posts
16,795 battles

I have been having problems with the new upgrade for the Shima , It is very laggy, i do know turret traverse is slow but even when your on a target it will not fire, it delays for a second or 2,  anyone else been having probs with it ?

Share this post


Link to post
Share on other sites
160
[AWP]
Members
784 posts
3,059 battles
17 minutes ago, scotty_geturown said:

I have been having problems with the new upgrade for the Shima , It is very laggy, i do know turret traverse is slow but even when your on a target it will not fire, it delays for a second or 2,  anyone else been having probs with it ?

It’s common on BB’s as well with their turrets. It’s like if they are less than 1 degree off, they will be green but it doesn’t mean they are fully on target. You have to let them rest there for a second while not turning or just wait a bit longer. Any turn with that slow of traverse will throw them off.

Share this post


Link to post
Share on other sites
1,463
[-K-]
Members
5,295 posts
9,129 battles

Are you referring to the new Legendary Module?

Share this post


Link to post
Share on other sites
Community Department
2,113 posts
520 battles
1 hour ago, scotty_geturown said:

Everything is on target yet it refuses to fire for a slit second, Thanks for your replies,

Have you checked the issue in safe mode? Do you have any connection issues?

Spoiler

Yrue9OvRAh4.jpg

Don't see mass bugs about. Do you have any mods installed? 

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×