Jump to content
Raiiako

7.6 Game is unplayably laggy on Mac

other ppl who experience the same thing  

11 members have voted

  1. 1. do you play on mac and have had lag?

    • yes, unplayable, stopped playing.
    • yes, mild
    • mac, and no.
      0
    • not on a mac, yes lag
    • don't play on mac, don't have lag, why you vote at all?

6 comments in this topic

Recommended Posts

13
[FAE]
Members
106 posts
1,698 battles

Don't even need to talk about game balance. Its so laggy I can't even render the ships fast enough to shoot them. 

Started being horrifyingly slow and crashing in 7.6. 

It really is so laggy that the game is unplayable. 

edit: I'm on the extreme lowest settings (very low), and lowest sound settings. So slow it won't render in time usually. 

Edited by Raiiako

Share this post


Link to post
Share on other sites
36
[-CIV-]
Members
229 posts
2,354 battles

That really sucks. :\ I know WG focuses more on PC gaming and consoles (like most of the industry), but running at least decently on Macs would set it apart. Does the problem persist even on the lowest graphics settings?

  • Cool 1

Share this post


Link to post
Share on other sites
779
[STW-M]
Members
2,044 posts
5,861 battles

I've already had pretty bad experience with technical issues on Mac ever since I started playing last year. Generally, the game crashes every third-fourth game, and sometimes it even costs my team the game because I end up sitting still within detection and firing range of multiple enemy ships without the chance to angle, retaliate, or even repair fires/floods.

This patch, however, I'm seeing ping shoot up to previously unimaginable heights, sometimes over 900 ping.

As a CV player, this really messes up my gameplay, and even with other ships it can be incredibly frustrating when you watch shells seemingly phase through enemy ships.

I've tried repairing the game integrity, but now I'm starting to be convinced that the only way to solve my problems would be to do a completely clean reinstall.

 

Share this post


Link to post
Share on other sites
26
[-TC]
[-TC]
Members
302 posts
1,729 battles

Why would you even play on a mac....

 

that's the real question.

 

Sucks to hear about your problems though.. those are never fun -_-

Share this post


Link to post
Share on other sites
1,268
[RKLES]
Members
7,195 posts
8,951 battles

I use Mac and what you are describing happens to me on extremely rare occasions. Often I get hit once in a while with that game crash bug, when that happens I force quite the game and quickly reopen it again to solve the problem.

Also make sure you are using very fast internet service and have internet cable plugged into computer instead of relying on wifi. ( Making sure you rule out other potential problems to help Wargaming Support narrow down any game issues.)

Share this post


Link to post
Share on other sites
66
[RCB4]
[RCB4]
Beta Testers
468 posts

i have been getting some lag since last patch

never gotten any before so it makes me think its something in the latest patch thats off

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×