Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
Lord_Magus

Game sticks on loading screen even after entering battle

5 comments in this topic

Recommended Posts

428
[VVV]
Members
2,460 posts

Has anybody had this happen before? It wasn't merely slow to load the battle, I was getting all the sound effects of battle (including the noise of spotting ribbons coming up, shells hitting my ship, etc) but I simply couldn't do anything for the full duration of the battle because it wouldn't let me out of the load screen.

Share this post


Link to post
Share on other sites
179
[BRZKR]
WoWS Wiki Editor, Supertester
702 posts
7,080 battles

Closing the game completely and restarting it usually fixes this problem for me. 

Share this post


Link to post
Share on other sites
680
[OPRAH]
Beta Testers
4,096 posts
13,282 battles

@Lord_Magus Similar occurrence for me last night on Raptor Rescue but I had no sound just the mission, team members, tips screen

Share this post


Link to post
Share on other sites
680
[OPRAH]
Beta Testers
4,096 posts
13,282 battles

@wacko17 No I do not have replay nor screen shots but for a 2nd time Raptor Rescue has failed to load past the Mission/Team Members/Tips screen. Of course without my CV Independence in the battle it was a loss and a waste of camo, signals and of course now the afk penalty battles and probable negative reports from the 6 six team mates

Share this post


Link to post
Share on other sites
680
[OPRAH]
Beta Testers
4,096 posts
13,282 battles

@wacko17 Failure to load in past the Mission/Team/Tips/Division screen again Random New Dawn Map once again a loss wasted credits a 1 game pink penalty and 20 minutes waiting hoping to load in before the end. No I do not have screen shots nor replays. Just the fact that it happens.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×