Jump to content
Sign in to follow this  
You need to play a total of 5 battles to post in this section.
awiggin

Why does this go on after updates?

12 comments in this topic

Recommended Posts

2,792
Members
9,980 posts

Since I really haven't been playing much, I had forgotten about this, but it really gets old, and once again reminds me of why I don't spend much on this game.

After an update, suddenly my guns all feel off. Can't cit anything. can't pen anything, can't buy a kill. Doesn't matter what ship, they all become ineffective. I'm suddenly doing half my average damage in ships I normally do well in.

This seems to go on after almost every update, and takes days before things feel "back to normal".

Anyone else ever notice this?

  • Bad 1

Share this post


Link to post
Share on other sites
Members
466 posts
8,499 battles

It's typical.   RNG aka "Rigged number generator"

Although i'm not sure why it only happens to you after patches.   Must be broken.

Share this post


Link to post
Share on other sites
2,710
[HINON]
Modder, In AlfaTesters, Beta Testers
6,498 posts
3,751 battles

Nope, never have. Nothing changes during the patch concerning those characteristics unless stated by the patch notes, so I'd say it's nothing more than your imagination.

  • Cool 2

Share this post


Link to post
Share on other sites
Alpha Tester
3,666 posts
7,182 battles
2 hours ago, awiggin said:

Anyone else ever notice this?

I notice that obvious confirmation bias is obvious. 

Share this post


Link to post
Share on other sites
2,093
[DAKI]
WoWS Wiki Editor
7,328 posts
6,609 battles

Nope, never noticed such a thing.

Share this post


Link to post
Share on other sites
51
[USFTW]
Members
192 posts
1,969 battles

If you aren't playing much then restarting after a new patch maby your aim is a bit rusty and it takes a few days to get back into your grove. Just a guess

Share this post


Link to post
Share on other sites
312
[TF_34]
[TF_34]
Beta Testers
1,059 posts
3,928 battles
7 hours ago, awiggin said:

Since I really haven't been playing much, I had forgotten about this, but it really gets old, and once again reminds me of why I don't spend much on this game.

After an update, suddenly my guns all feel off. Can't cit anything. can't pen anything, can't buy a kill. Doesn't matter what ship, they all become ineffective. I'm suddenly doing half my average damage in ships I normally do well in.

This seems to go on after almost every update, and takes days before things feel "back to normal".

Anyone else ever notice this?

I'll take "WTH" for 600, Pat...

I would love to take a ride on this merry-go-round as I have noticed something similar, but not related to patches...but I wont. Your problem, like mine, was succinctly covered in your first sentence:

"Since I really haven't been playing much."

I take many breaks from the game for school and work and notice that, when I come back, my shooting is like a sh*t sandwich. After reflection I noticed that I was going from US to KM to RN without really working a set ship to get a handle on the guns before jumping lines. Makes sense...we all want to maximize our daily wins.

Its just rust--i know, I know...after xxxx battles, we all know our ships and their guns, right? Nope...its easy to lose the touch required on these guns after a break from the game. Dont sweat it too much...you will be back to nuking people in no time.

Share this post


Link to post
Share on other sites
786
[NG-NL]
Members
5,030 posts
8,269 battles

Nothing but rusty aim. I've found it's most pronounced my MO/Montana/Yamato, but it's happened in my T10 cruisers too.

Share this post


Link to post
Share on other sites
475
[4HIM]
Members
1,813 posts
4,138 battles
4 hours ago, Fog_Repair_Ship_Akashi said:

I notice that obvious confirmation bias is obvious. 

There's a cap for that

captain+obvious.jpg

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×