Jump to content
Sign in to follow this  
You need to play a total of 5 battles to post in this section.
Silvers_

Twitch Camo/Texas

16 comments in this topic

Recommended Posts

0
[RELSH]
Beta Testers
4 posts
86 battles

https://twitch.worldofwarships.com/en/

 

So I have twitch prime because I have Amazon prime. Linked my twitch account like it says. I had done this before with teh Italian T5 prem event and that ship is there. However followed everythign and the Texas is not showing up in my port. Is there a level you have to be to get it? I'm currently at 11 almost at 12 so not sure if I need to be 15 or not.

 

Should  I send a ticket to support?

Share this post


Link to post
Share on other sites
263
[SUCIT]
Members
783 posts
3,493 battles

I believe your account has to be a certain level.  I'm not entirely sure which level, but I remember reading it somewhere.  

Either way, it's not hard at all to level up your account.  It should only take you ~120 battles to get to level 15.  The whole leveling system means nothing outside of rewards either, so just finish it off and you're good.  

Edit;  Just looked on the twitch prime page and it does say at the bottom "Some items won't be accessed until your account reaches a certain level."  I can only assume that you have to be level 12, which is what 90% of the events require.  

Edited by XpliCT_PaiiN

Share this post


Link to post
Share on other sites
1,619
[SYN]
[SYN]
Members
6,711 posts
11,331 battles

Are you using a steam account? Had a clan mate that ran into some complications due to steam.

 

Edit: Also think I saw something about being level 12 as requirement.

Edited by Kapitan_Wuff

Share this post


Link to post
Share on other sites
0
[RELSH]
Beta Testers
4 posts
86 battles

nah it's my normal WGNA account. I'm almost to 12 so maybe that is it. 262 away from 12. Will post if I get the ship once I hit 12.

Share this post


Link to post
Share on other sites
0
[RELSH]
Beta Testers
4 posts
86 battles

well hit 12 and nada. Guess time to send in a support ticket

Share this post


Link to post
Share on other sites
159
[AWP]
Members
780 posts
2,950 battles

Did you restart the game and log back in? Did you make sure you claimed it on twitch first? If you did both of those submit a ticket.

Share this post


Link to post
Share on other sites
99
[WAG]
Members
379 posts
7,268 battles

 accidentally made a second Twitch account. Didn't notice since I rarely ever use twitch. The solution was to unlink my Wargaming account, and link to the new Twitch account, then link back. Got my Texas. Pays to not try complex actions late at night :-p

Share this post


Link to post
Share on other sites
0
[RELSH]
Beta Testers
4 posts
86 battles

yeah did both of those. just logged out and back in thinking that may be the issue but nope nothing. So took a screen pic of my twitch prime showing claimed and then of the "port" showing my american boats and the Texas not being there. Ticket has been submitted.

 

I've gotten the t5 Italian ship awhile back from the Twitch Prime event what 3-6 months ago so I know it's set right.

Share this post


Link to post
Share on other sites
1,818
[V_KNG]
Beta Testers
9,268 posts
19 minutes ago, Belyy_Klyk said:

Did you restart the game and log back in? Did you make sure you claimed it on twitch first? If you did both of those submit a ticket.

try logging in with Twitch

Share this post


Link to post
Share on other sites
62
[SSBN]
[SSBN]
Members
292 posts
4,947 battles

Did you “claim your loot” on twitch?

Share this post


Link to post
Share on other sites
132
Beta Testers, In AlfaTesters
583 posts
9,236 battles

Unlink then Relink your Twitch account.  I had a similar issue: Already have Prime, max lvl acct, and got nothing.  Logged on with Twitch, didn't work.  So I kinda got mad, unlinked then relinked.  Worked. :Smile_great:

 

Share this post


Link to post
Share on other sites
132
Beta Testers, In AlfaTesters
583 posts
9,236 battles
1 minute ago, gmrbull said:

Did you “claim your loot” on twitch?

He has stated that he followed the instructions that were given.  So it's likely that he already did that. :Smile_Default:

Share this post


Link to post
Share on other sites
3
[-AJ-]
Members
15 posts
472 battles

Just tried it and worked for me. Level 15, linked accounts, and now Texas arrives in port. Thanks WG and Twitch!

Share this post


Link to post
Share on other sites
231
[SF-3]
Members
1,442 posts
7,901 battles
1 hour ago, Herr_Reitz said:

try logging in with Twitch

Thats what worked for me.

I created Twitch account using my Amazon prime, then linked to my WG account, then logged in using twitch. This could also have been a coincidence, maybe it just takes like 30 minutes for it to show up in game.

Share this post


Link to post
Share on other sites
1,479
[AHOY_]
Beta Testers
6,419 posts
3,411 battles

Be sure to "Claim" the reward while you're logged into Twitch, before logging into WoWs. Not all Twitch Prime bonuses are auto-claimed.

  • Cool 1

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×