Jump to content
NorthernStrangler

Application crashes at random since last update

7 comments in this topic

Recommended Posts

Members
23 posts
9,381 battles

image.thumb.png.182d1d61e6df16727d45e9912aac7338.png

 

This keeps happening at random... I don't know why. It has since the Space sim came into play, more or less last 2 weeks. 

 

The game will not allow me to resume until the current match is over, and its random... Any thoughts? Assistance? 

Share this post


Link to post
Share on other sites
0
[WAVE]
Members
1 post
4,247 battles

I've been getting it too. On my main pc it's been crashing for a month now and just started since the space battles crashing on my laptop. 

Share this post


Link to post
Share on other sites
63
[DRACS]
Supertester
725 posts
12,005 battles

I have been getting the same crash, at least once a day since the last patch.

Share this post


Link to post
Share on other sites
3
[TWFT2]
Members
9 posts
3,104 battles

So basically what this is saying is that the program tried to use a piece of memory that is not available, corrupted or it does not have access to. It doesn't give much information that I know how to use but there is a few things I can think of to potentially resolve this issue. Each of these steps are potentially decreasing the security and/or stability of your system and may have unintended side affects. It is however unlikely and if you have an anti-virus AND anti-maleware software running on your computer, it should be almost risk free. However there is a chance and you need to take that into consideration before attempting these steps.

First go to the WoWS install folder (should be were all your other steam games are unless specified otherwise when installed) Right click and go to options. Find the tick box down the bottom that says "read only" uncheck that tick box and select "apply to all subfolders" when the it pops up. This might take awhile to complete depending on how many files and folders are in that directory. As this game is still in beta and the updates dont ever seem to repack, I imagine is a freaking mess in there. If the folders and files are still read only after attempting that, thats fine as they are tagged to be read only and will revert back if ever changed.

Once that is complete, go into the folder and find the executable/application(not the launcher, the one that is called world of warships or something similar) right click and go to properties under comparability tab, check the "run as admin" check box. Click security and make sure there is a user group that is the user you sign in as or a group called "everyone". Press apply and close.

Additional options
-----------------------------------------------------------------------------------------------------------------------------------------
you can also limit or turn of data execution prevention if none of the previous things have fixed the issue. Got control panel, type "system" into the top right hand search box. Click the green or blue text that comes up in the search called "system" click advanced options. Memories a little off here but I think you click a thing called "system performance" or something like that. In there should be a tab called DEP or data execution prevention. Click that tab and change it from windows programs only to exclude the ones I select. Press add down the bottom. Navigate to the same World of warships folder and add both the exe and the launcher. Some files will not be able to run without DEP as they use windows resource management to allocate resources and windows resources management uses DEP. Click apply and close the window.

You can try turning off user account control. Open your start menu and type in "user account control settings" click the relevant result in the search box. There could a be a number of ways this screen looks. The most common will be a slider thingy that has different levels on it. You want to drag it all the way up or down to the setting that reads "never notify me".

You will potentially have to restart your computer after making all these changes depending on what your setting were before changing them. Go ahead and restart and see if any of this helps.

If none of this helps you will have to look into repairing the install or check your hard disk or ram for errors and corruption. I will go into this if people find the already mentioned things do not help. Its a little more involved and will have some wait times as your computer runs the checks.


Sorry if this isn't well written or I have the names of things wrong. I am in bed with the flu and don't have the game installed on my laptop(Although now i think of it, that should be a thing I do) nor do I feel like double checking every step.
Good luck and fair seas!

  • Cool 1

Share this post


Link to post
Share on other sites
3
[TWFT2]
Members
9 posts
3,104 battles

Also, this is not a virus. That is a windows error message initiated by the WoWS application.

Share this post


Link to post
Share on other sites
3
[TWFT2]
Members
9 posts
3,104 battles

I should also mentioned I am not affiliated with or speak on the behalf of WG.net. I am just an IT consultant attempting to help out another fellow gamer.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×