Jump to content
Sign in to follow this  
You need to play a total of 5 battles to post in this section.
Rickster1998

Twitch not linking

6 comments in this topic

Recommended Posts

3
[TAZZ]
Members
56 posts
2,881 battles

I have been trying to link my account and every time I do, it loads and loads and comes up with "This site can’t be reached".
Does anyone know a fix to this?

Edited by Rickster1998

Share this post


Link to post
Share on other sites
15
[OPG]
[OPG]
Beta Testers, In AlfaTesters
191 posts
5,684 battles

Mine went to the russian portal the first time i tried. Then I saw this post and gave it another try and it worked perfectly fine. I have no idea wth is going on, sorry.

Share this post


Link to post
Share on other sites
657
[WOLF1]
[WOLF1]
Members
2,865 posts
1,338 battles

I started at Amazon, made my Twitch I already had into prime, then hit the loot button for WoWS and linked it.  Worked fine in Chrome.

 

Share this post


Link to post
Share on other sites
3
[TAZZ]
Members
56 posts
2,881 battles
3 minutes ago, mavfin87 said:

I started at Amazon, made my Twitch I already had into prime, then hit the loot button for WoWS and linked it.  Worked fine in Chrome.

 

Pretty much the same except for it will not link and it sends me to wargaming.net/personal vs NA.wargaming.net/personal

Share this post


Link to post
Share on other sites
86
[-TXT-]
Members
348 posts
9,593 battles

ez to do.  login in you  na portal hit Account management  under your user name . you will see the twitch logo. hit it and then authorize and boom done

 

Edited by warp103

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×