Jump to content
TheAshenWolf

Twitch Prime Port Not Working

20 comments in this topic

Recommended Posts

2
[OPG]
[OPG]
Members
6 posts
8,712 battles

I have my Twitch account linked to my Login for Wargaming, am a Twitch Prime member, yet the port is still grayed out. Is there something I'm missing? Do I need to link something in addition?

Share this post


Link to post
Share on other sites
22
[7RET]
[7RET]
Beta Testers, In AlfaTesters
114 posts
6,358 battles

I don't think it's actually live yet except the achievement.

Share this post


Link to post
Share on other sites
0
[NEIN]
Beta Testers
12 posts
3,100 battles

i'm having the same issue, i figure the prime loot part of it is not active quite yet, so we have to wait till it shows up

Share this post


Link to post
Share on other sites
22
[7RET]
[7RET]
Beta Testers, In AlfaTesters
114 posts
6,358 battles

You have to log into Prime and claim it. If it doesn't work after that it's being looked into

Share this post


Link to post
Share on other sites
Members
463 posts

I found that when I linked it went to my EU account, checking the Twitch page the mouse over points to EU

 

I severed that link and linked my NA account, did I screw up the rewards this way or would they apply to both? I abandoned my EU account at end of 17

 

 

EDIT: restarting my client showed the port for me on NA :)

Edited by fourteenfour

Share this post


Link to post
Share on other sites
6
[-V1-]
Members
158 posts
5,857 battles

I tried this offer from twitch....Could not figure out of to link them....Got a sign on screen to war gaming net and no matter what i put in there it didnt work. Does it want me to make up a new warships account  at that point ?

 

Share this post


Link to post
Share on other sites
2
[OPG]
[OPG]
Members
6 posts
8,712 battles

WG posted the instructions. I forgot you have to login to Twitch and click claim offer, under the Crown icon (just like every other Prime offer for games - lol).

Share this post


Link to post
Share on other sites
Beta Testers
109 posts
8,609 battles

damn i claimed the loot BEFORE linking my WG account to Twitch , assuming i would just get a code or something , damn guess im out of luck :(

 

ACTUALLY... wth .. It works ! :DDDD

Edited by S4breh4wk

Share this post


Link to post
Share on other sites
Members
1 post
460 battles

Same here, not working at all, but I have it linked and have claimed everything from twitch site.... curious... anyone else still having this issue?

 

Share this post


Link to post
Share on other sites
1
[KRON]
Members
3 posts
744 battles

I am unable to get the port as well even after linking my account, and trying to login with twitch, and i have also rebooted my client.

Share this post


Link to post
Share on other sites
1
[DNGRZ]
Beta Testers, In AlfaTesters
14 posts
2,473 battles

I am having the same issue.

Share this post


Link to post
Share on other sites
2
[B-W-M]
[B-W-M]
Beta Testers
30 posts

Same Issue Linked Account with Twitch Prime I have the Flag, The Twitch Prime Mission for the Texas but it still Won't Let me use the Twitch Prime Port Or have my Captain Kappa.

Share this post


Link to post
Share on other sites
353
[NAVY]
Members
1,009 posts
3,791 battles

I followed the instructions but cannot select the Twitch Prime port either. I signed up for a Twitch Prime account, linked my WoWs account with Twitch Prime, clicked on the PRIME LOOT crown and claimed my WoWs loot, and then logged into the WoWs client. I even tried logging in to WoWs via my Twitch Prime account.

I got Texas with the camo, crates, and flags, and I got the personal Texas Conquest missions to que up as well. I completed all of those and still cannot access the Twitch Prime port. I'm going to send in a support ticket to WG and see if they can offer any explanation or help because I have yet to find a solution by searching on the forums here, WoWs Reddit, or any of the other WoWs forums.

Share this post


Link to post
Share on other sites
353
[NAVY]
Members
1,009 posts
3,791 battles

I submitted a support ticket earlier today, on Friday, and this is the response, down below, I got back from WG. Apparently, the Twitch Prime port is not part of the Twitch Prime loot for the event that started on April 5th and ends today, Friday, May 4th. I went and read through the Twitch Prime events again, and it is apparently part of the previous month's event from March 5th - April 4th, https://blog.twitch.tv/twitch-prime-members-get-a-shipton-of-world-of-warships-loot-including-commander-kappa-32715b3fe488.

If you signed up for Twitch Prime from March 5th through April 4th, then I assume you should be able to access the Twitch Prime port; however, not 100% sure on that one. Maybe a dev or mod will pop on the thread and clarify.

Hi daVinci761st,

Thank you for getting back to us.

We understand that you might have some concerns about your account.

Regarding this, may we inform you that the Twitch port is not given for the event right now for Twitch Prime subscription. Take note that there is a different set of prizes for the month of April. This month we are giving these items
for players who have linked their Twitch prime to their Wargaming.net account:
 

  • USS Texas, tier V premium ship
  • 1x port slot
  • Dedicated combat missions
  • 1x permanent Twitch-branded camouflage for USS Texas (top reward in mission chain)
  • 15x consumable Twitch-colored camouflages
  • Twitch-branded memorable flag


Hope that this answers your inquiry.

Have a nice day!

Share this post


Link to post
Share on other sites
Members
2 posts
206 battles

I still can not get the port to work. I sent a ticket to WoWS and they said it was a Twitch Prime issue. I sent a ticket to Twitch CS and they said it was best handled by Twitch Support. They also said they passed along my issue and I can expect a response within 24 hrs., which was a couple days ago. Like many others I have all the other Twitch Prime perks like the Texas, the camo, the achievement, and the missions.

Should I try to unlink my account and then relink it, even though I have the other twitch prime stuff? IDK. Looks like a nice port would love to use it! :)

Share this post


Link to post
Share on other sites
234
[T-RIP]
[T-RIP]
Members
1,044 posts
8,076 battles

@slycy did you manage to get it working? mine is still out of action.

Share this post


Link to post
Share on other sites
0
[MUG-T]
Members
2 posts
1,048 battles

Don't worry I have watch streams for nearly 24 hours and still have not gotten one but got three for my first 7 hours of watching. Chance must be really LOW not a good experience so far. 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×