Jump to content
You need to play a total of 5 battles to post in this section.
Komrade_Rylo

Tired of invisfiring ships

60 comments in this topic

Recommended Posts

1,102
[CHASE]
Beta Testers, In AlfaTesters
2,960 posts
12,425 battles

These invisible ships firing at me that I can't see is really starting to piss me off.

 

Spoiler

Kek. He was invisible for a good 5 minutes and it was near impossible to land good hits on him.

shot-18_02.13_23_55.37-0929.thumb.jpg.6616b0a6abb95b0a7c3f761bf516aa9e.jpg

 

  • Funny 2

Share this post


Link to post
Share on other sites
975
[4HIM]
Members
2,908 posts
11,210 battles

Me too.  Been burned down by a rainbow arc of HE originating from open ocean too many times.  

Share this post


Link to post
Share on other sites
764
[LOU1]
Members
4,094 posts
11,410 battles

I can only invisi-fire against ships that sail predictably  I get where they are just out of my range and fire into their path.  There is also firing over obstacles at ships spotted by my Team mates.  I always throw a few shells into a BBs path whenever I have the opportunity to do it without anyone spotting me because they usually cannot react quickly enough. The trickiest/hardest is the firing ahead trick.  The good thing is that anyone can do it if they are watching for an opportunity.   I have been hit from out of the blue on occasion, mainly when I am tunnel visioned.  That's why I vary my course and speed as I go along.

(Sorry, can't really tell what the picture is showing.)

Share this post


Link to post
Share on other sites
2,420
[-KIA-]
Clan Supertest Coordinator, Supertester, Privateers, Volunteer Moderator Coordinator
6,496 posts
8,121 battles

So whenever a ship fires, it should be spotted no matter if it's behind a huge island? Hmm.. :hyperthonkang:

  • Cool 3

Share this post


Link to post
Share on other sites
764
[LOU1]
Members
4,094 posts
11,410 battles

Just remembered, depending on your graphic and/or zoom settings they could be firing from inside smoke.  Zoomed in, smoke does not show.  I have to back the zoom up a bit to see the boundaries of the smoke so I can gauge where the ship will exit.  Just happened several times over the last couple of hours.  Tracking a ship on zoom at 10km or so and then, poof, no ship.  Zoom out and see the smoke.  Zoom in and look for magic tracers to get an aiming point.

Edited by ExploratorOne

Share this post


Link to post
Share on other sites
Members
9,126 posts
10,596 battles

Aside from the usual reasons why you can't see someone firing at you, there is this, and I use it almost every round: I see a target that will be in range by the time my shells get there, so I lead and fire.  This is frequently what's happening when someone is "invisifiring", more, should my target come within my range before the 20 seconds is up, I'm then detected.

 

Cruisers primarily use this, they're squishy, and any extra "safe" shots are worth the effort. Only a truly highly skilled player can stay just beyond range and walk their shells in for hits, even more, it completely depends on the target to keep course and speed constant, and heading towards you in the vast majority of cases, so you can back up and repeat. It requires an absurd amount of patience to use this as a primary gunnery tactic.

Share this post


Link to post
Share on other sites
1,102
[CHASE]
Beta Testers, In AlfaTesters
2,960 posts
12,425 battles
10 minutes ago, Th3KrimzonD3mon said:

Aside from the usual reasons why you can't see someone firing at you, there is this, and I use it almost every round: I see a target that will be in range by the time my shells get there, so I lead and fire.  This is frequently what's happening when someone is "invisifiring", more, should my target come within my range before the 20 seconds is up, I'm then detected.

 

Cruisers primarily use this, they're squishy, and any extra "safe" shots are worth the effort. Only a truly highly skilled player can stay just beyond range and walk their shells in for hits, even more, it completely depends on the target to keep course and speed constant, and heading towards you in the vast majority of cases, so you can back up and repeat. It requires an absurd amount of patience to use this as a primary gunnery tactic.

 

No, the ship was spotted, the game just didn't render his ship. I could sorta hit him but I had to try and aim shells at the floating ball of fire

Share this post


Link to post
Share on other sites
1,102
[CHASE]
Beta Testers, In AlfaTesters
2,960 posts
12,425 battles
30 minutes ago, ExploratorOne said:

(Sorry, can't really tell what the picture is showing.)

 

Nothing was showing, that's the point. The Bismarck was spotted and didn't render in for 5 whole minutes of him being continuously spotted.

Share this post


Link to post
Share on other sites
1,566
[REVY]
Members
6,454 posts
5,168 battles
39 minutes ago, Fog_Battleship_NCarolina said:

These invisible ships firing at me that I can't see is really starting to piss me off.

 

  Reveal hidden contents

Kek. He was invisible for a good 5 minutes and it was near impossible to land good hits on him.

shot-18_02.13_23_55.37-0929.thumb.jpg.6616b0a6abb95b0a7c3f761bf516aa9e.jpg

 

They removed stealth firing, but apparently it wasn't good enough for you.

  • Cool 1

Share this post


Link to post
Share on other sites
659
[13TH]
Members
4,898 posts
8,851 battles

For whatever reason invisa firing is becoming more common of late, I do not not why it is just that it is, I suspect since the new ..you fire and you become visible change players have learned other ways to invisa fire, happens now almost as often as before the change

 one thing I’ve noticed is ships firing that Ive already spotted because they fired then I see a disturbance were I think they are because they just fired but still invisible for a full 5 seconds and are only visible for a short time when they do appear and then disappears again

Edited by HMCS_Devilfish
  • Cool 1

Share this post


Link to post
Share on other sites
1,082
[ADR]
Members
4,447 posts
15,465 battles

Most of the time it's a ship behind an island, in the case of that Bismarck..  it's WG's garbage fade in render system, it's entirely TOO slow and it can take 10 seconds for a ship to "phase" in. 

  • Cool 1

Share this post


Link to post
Share on other sites
215
[WAG]
Beta Testers
763 posts
6,919 battles

guys, hes pointing out a glitch, not complaining about game mechanics. stop hammering on him saying 'remove invisfiring' when he isnt, and read the whole post.

  • Cool 2

Share this post


Link to post
Share on other sites
1,102
[CHASE]
Beta Testers, In AlfaTesters
2,960 posts
12,425 battles
4 minutes ago, Shadowrigger1 said:

Most of the time it's a ship behind an island, in the case of that Bismarck..  it's WG's garbage fade in render system, it's entirely TOO slow and it can take 10 seconds for a ship to "phase" in. 

It took him 5 minutes to render in. I don't have a slow PC either.

Share this post


Link to post
Share on other sites
659
[13TH]
Members
4,898 posts
8,851 battles
1 minute ago, GX9900A said:

guys, hes pointing out a glitch, not complaining about game mechanics. stop hammering on him saying 'remove invisfiring' when he inst, and read the whole post.

And pray tell ... what Glitch is he talking about?

Share this post


Link to post
Share on other sites
1,102
[CHASE]
Beta Testers, In AlfaTesters
2,960 posts
12,425 battles
2 minutes ago, HMCS_Devilfish said:

And pray tell ... what Glitch is he talking about?

 

Ships taking 2 years to render in. I thought people would find it funny and open the spoiler

  • Cool 1
  • Meh 1

Share this post


Link to post
Share on other sites
4,400
[WOLF7]
Members
12,498 posts
23 minutes ago, HMCS_Devilfish said:

And pray tell ... what Glitch is he talking about?

Ships not rendering....lots of players are reporting it, saw it myself during xmas....

Aoba firing at me from 11k, across open water, invisible the entire time....

Share this post


Link to post
Share on other sites
2,378
[WUDPS]
Beta Testers, In AlfaTesters
5,169 posts
4,954 battles

Saw it today in my Zao. Enemy Zao blasts me within 11k with AP on open ocean....kills me...never saw him render at all. 

Share this post


Link to post
Share on other sites
2
[TSIOF]
[TSIOF]
Beta Testers
102 posts
2,591 battles

I haven't experienced this glitch too much, or at least it was very minor at the time.

Share this post


Link to post
Share on other sites
35
[HINON]
Privateers
106 posts
5,060 battles

Never seen it myself personally but i've had friends say they've seen this. 

Share this post


Link to post
Share on other sites
Members
376 posts
5 battles
3 hours ago, Fog_Battleship_NCarolina said:

It took him 5 minutes to render in. I don't have a slow PC either.

That's called a bug, stop crying and report it to WG directly already. 

Share this post


Link to post
Share on other sites
1,082
[ADR]
Members
4,447 posts
15,465 battles
11 hours ago, Fog_Battleship_NCarolina said:

It took him 5 minutes to render in. I don't have a slow PC either.

Mine is a quite fast computer too with at 1080TI.  granted I don't have an SSD. but the render performance of the game is subpar at best.  I can consistently watch shells being fired and ships not rendering in until the shells are nearly at my ship. the further the ship is the longer it takes to rez in.  it's usually pretty fast up close.

 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×