Jump to content
Phasferous

Winter Mystery Mission Bugged

5 comments in this topic

Recommended Posts

127
[NG-NS]
Members
552 posts

Anyone else having problems with the "Winter Mystery" mission? The personal Mission I mean? I've won 4 battles, and over those 4 battles I've killed 4 ships. However the mission is counting neither. Also on my current session record I've lost 3 battle, but across those three battles I've killed 2 ships. So I should have completed the part that says "Destroy 5 ships" but that's still showing as empty/no progress. What is going on? Anyone else having this problem?

 

Thanks!

 

Images of proof of kills and victories are as follows:

2018-01-15_1642.thumb.png.df080c56d9643c1c2074be73c41f8354.png

2018-01-15_1643_001.png.2866960118b8212f573a3b3b6f77a281.png

2018-01-15_1643_002.thumb.png.bdb6eac065827732b3c9393d62bac073.png

2018-01-15_1644.thumb.png.b8ed3824e8ae213045f9a79dcd028665.png

2018-01-15_1644_001.thumb.png.fa18dcd462d8a3037ff49bbab6a1c351.png

2018-01-15_1644_002.thumb.png.6662c1ff2c151c6f1176c4d468456d1a.png

Share this post


Link to post
Share on other sites
127
[NG-NS]
Members
552 posts
1 minute ago, awiggin said:

It's been broken for weeks and keeps showing up.

There have been several threads about it.

Oh okay. I wasn't away and didn't see any threads on the first page on the Support Form about it. Good to know it's been made aware and it wasn't going to screw me over on the rewards. Any idea if it will be fixed? Or is it not actually supposed to show up at all and it's showing up due to it being borked?

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×