Jump to content
You need to play a total of 5 battles to post in this section.
skyman100

Steven Seagal Voice not working?

16 comments in this topic

Recommended Posts

Beta Testers
84 posts
2,094 battles

I just recently got the Missouri and put Steven Seagal on my ship but the voice is not working. Any help with fixing this?

Share this post


Link to post
Share on other sites
1,826
[ARRGG]
[ARRGG]
Members
5,770 posts

I disabled it.His Crack induced enthusiasm is the worst. But if you "really want him back.....  Reset the voice in audio change the settings then change them back" 

Share this post


Link to post
Share on other sites
231
[SYN]
Members
346 posts
6,179 battles
15 minutes ago, skyman100 said:

No I remember using him before and it working.

Let me channel my inner Seagal...

 

s             a          r                c              a             s...zzzz

Share this post


Link to post
Share on other sites
1,752
[YORHA]
Members
3,338 posts

I hadn't even noticed that I just had 2 battles with him as Captain and his voice was missing. Saved me deleting the files.

Perhaps WG's contract with him was up?

Share this post


Link to post
Share on other sites
2,261
[PVE]
Members
9,766 posts
7,472 battles

I played him this morning and he was his usual drugged self. If I get a chance tonight, I'll try him again.

Share this post


Link to post
Share on other sites
Members
2,585 posts
12,434 battles

Ships on fire...with all the urgency of me doing laundry.... At least with the ARP girls they are screaming, I don't know what they are saying but it seems important.

Share this post


Link to post
Share on other sites
725
[0456]
[0456]
Members
2,809 posts
7,992 battles

lol I shake my head a little bit. I don't dislike his character or voice at all. Acting, whatever. I'm fine with him- but I couldn't stand him when his captain first came out. Straight to reserve. He sounds like he says everything on an inhale. 

 

But some ships do benefit from his captain skills so now I've been running him a lot on Cleveland, Atlanta and Indianapolis. Working just fine on my rides  

 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×