Jump to content
You need to play a total of 5 battles to post in this section.
gonowgetdown

Windows update caused drop in frames...

5 comments in this topic

Recommended Posts

47
[PRSR-]
Members
177 posts
6,281 battles

Windows 10 performed a rather large update yesterday. Included a few restarts. The first thing I notice is the start menu has gone back to the original with bloatware and all. Then I ran WOW and it was plying at ~38 frames or worse. 

This is not my cpu or my graphics cards; both have more than enough juice to handle this game and it worked at 70hz at 2K resolution with full graphics before with no issues.

Any ideas?

Share this post


Link to post
Share on other sites
2,819
Members
5,574 posts
7,121 battles

Any time I see someone having issues, I fallback on this standard..

 

Kill the updater from running via task manager, and start the game via the wows.exe in your install folder.

 

Not many say this even though it's been a thing since the new updater came out, but it fixed a crap ton of frame rate issues and getting booted using this method.

 

I don't have the new updater myself, so I've never tested it, but many swear by it.

 

It's at least something easy to try.

Share this post


Link to post
Share on other sites
Members
3,492 posts
6,195 battles

Kill the updater from running via task manager, and start the game via the wows.exe in your install folder.

The update was a Windows update - not a WoWs update.  Likely things changed in Windows that affected the game - maybe with an update to a video card driver which is the first place I would look. 

Share this post


Link to post
Share on other sites
23
[TORND]
Members
206 posts
11,336 battles

I have a 3 year old laptop with NVidia card of that vintage, so it's just usable and I have to baby it a bit.. A few ideas:

You want to make sure your power settings are on high. It may be that the update reset it to balanced, which just won't cut it on mine.

If you have OneDrive or other cloud syncing set to automatic, make sure it's at least paused. On my OneDrive icon in the notification area, I can right click and pause it for various amounts.

There's check the NVidia app for updates.

Last resort is task manager to see what else is running. I keep a shortcut to it on my task bar. You can kill any other program that seems to be using cpu. Also, in the startup tab you can see what's starting when you restart your machine. I have lots of things turned off.

Finally, it sometimes helps to restart your machine to kill off things which may be hanging around in the background.

Even with all that, I still can't run it at fully optimized settings. Have to use the GeForce Experience app to turn down the graphics settings by about 25%

nvidia settings.png

Share this post


Link to post
Share on other sites
2,819
Members
5,574 posts
7,121 battles
27 minutes ago, CylonRed said:

 

 

The update was a Windows update - not a WoWs update.  Likely things changed in Windows that affected the game - maybe with an update to a video card driver which is the first place I would look. 

It's always a good idea to try that method regardless of what's going on.

 

Even a Windows update can throw a wrench into the installer.

 

Hell, looking at the installer funny can cause issues...

Edited by Wulfgarn

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×