Jump to content
Sign in to follow this  
You need to play a total of 5 battles to post in this section.
Ensign_Cthulhu

The definition of supreme frustration...

7 comments in this topic

Recommended Posts

10,554
[ARGSY]
Members
18,363 posts
12,799 battles

...is having not one but TWO enemy battleships less than 5km away from you, your nearest friendly ship has just died to enemy fire (so no teamkill risk, which considering what happened earlier this afternoon was just as well), they are missing with every shot...

 

...and your ping lag is ONE THOUSAND EIGHT HUNDRED MILLISECONDS AND RISING.

 

Had it been a tenth of that, I'd have had both dead to rights. But when your shells and torps leave your ship a two to three count after you click the mouse, how the heck are you supposed to hit ANYTHING? It should have been my Danae's moment of glory, but instead... nothing.

 

To make things worse, I even managed to circle round one of them and survive long enough to RAM him. And to add insult to injury, he had just enough health left to survive, repair his damage and heal before he flooded to death.

 

And then to rub things in even FURTHER, I get out of that battle and decide to take my Tier 1 pan-Asian ship into battle (because accidental teamkilling in a Tier 1 is almost impossible without a lot of bad luck...) and the ping delays get so bad I can't even take her out. I keep getting logged off. So at that point I just quit and logged out of the game.

 

The kicker...

 

There was ONE FREAKING XP left to get before I collected a container. 

 

What's with it? I'm tempted to say "It's because every man and his dog is on the NA server now that it's the weekend, trying to grind out a free Vampire", but is that actually how it works? (If it is I can't blame them; that's why I was there too.)

Edited by Ensign_Cthulhu

Share this post


Link to post
Share on other sites
2,707
[O_O]
Members
6,228 posts
14,416 battles

I am not having these problems, and I don't have super mega high speed internet.

Share this post


Link to post
Share on other sites
3,640
[RLGN]
Members
13,548 posts
23,672 battles
1 hour ago, Ensign_Cthulhu said:

What's with it? I'm tempted to say "It's because every man and his dog is on the NA server now that it's the weekend, trying to grind out a free Vampire", but is that actually how it works? (If it is I can't blame them; that's why I was there too.)

 

Windows 10 has been doing a huge pita update recently; if it hasn't already hasppened in/to your system, that may be the issue. (Atleast, that seems to be what was happening to me recently; lag from hell; next day 'Please restart to instal latest system update!' 

Edited by Estimated_Prophet

Share this post


Link to post
Share on other sites
10,554
[ARGSY]
Members
18,363 posts
12,799 battles

Aha. But the same thing in two separate sessions ten hours apart? Good grief. Maybe I should just turn the cursed thing on right now and leave it running, so that when I get some game time it's finished pulling its stupidities and is ready to serve my needs.

Share this post


Link to post
Share on other sites
1,082
[ADR]
Members
4,447 posts
15,465 battles

Windows 10 has been jerking lots of things up.. But your PING being bad means you need to be talking to your ISP,  reset your modem/router.    Windows 10/ Antivirus will make you stutter freeze, not make your Ping explode.

Share this post


Link to post
Share on other sites
10,554
[ARGSY]
Members
18,363 posts
12,799 battles

I let things run without attention all morning, and when I got to it in the afternoon everything was beautiful.

 

I even managed to redeem my two-battleship frustration! If I'd done it in Random it would have been a double strike. Number one was an aimed shot; number two was CTRL-X, yeah, it's on; squirt the torps out and pray...

 

RNG answered me. :)

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×