Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
xXLasre15Xx

World of Warships Keeps Crashing

23 comments in this topic

Recommended Posts

xXLasre15Xx    1

Attached are the screenshots of all crashes. I've already tried running the game in safe mode. Haven't reinstalled it yet due to the time it takes. World of Warships crashes occasionally, yet not always. It is always during or immediately after loading the game, and appears to be from the fact that the game cannot sometimes find files. After running the client repair function, the issue still occurs. 

Recreation process: Open World of Warships. If bug occurs, recreation successful. If not, close and try again.

Screenshot (1).png

Screenshot (2).png

Screenshot (3).png

Screenshot (4).png

  • Cool 1

Share this post


Link to post
Share on other sites
USMCGal    75

Can you try setting all your graphics down to low and see how it runs? Don't know if you have tried this or not. Also try removing any and all mods.

  • Cool 1

Share this post


Link to post
Share on other sites
AJTP89    182

Interesting. Yesterday after updating, I tried to load the game, and it crashed. Cleared mods, still crashed. Restarted computer, still crashed. So I reinstalled. It had been buggy for a bit anyway, always brought me to my MO no matter what ship I was looking at when I logged out. It refused to save any preferences I selected in game (mini-map rings etc). Showed the Halloween message on log-in every time. I saved my preferences file, the training room mod, and uninstalled. Using the old launcher, took a couple hours to reinstall. Dropped in the preferences folder (which has my mouse key binds and replay code), the training room mod, and reinstalled Aslain's mods. Problem solved. Luckily I had some things to do while it installed, and watched Flamu's stream for a bit, but it still took a while. But worth it.

 

OP, I'd say just reinstall. Maybe get it going before you head to bed for the night. Make sure you save your preferences file though, then you don't have to reset everything.

Share this post


Link to post
Share on other sites
Herr_Reitz    1,347

If you haven't tried this... rename the preferences.xml file to something else... like oldpreferences.xml. Do this without the game being loaded. Then start the game, see if you get past your problem.

 

 

Share this post


Link to post
Share on other sites
USMCGal    75

What they should do is fix their unstable installer so you should not have to reinstall the game every time it is patched and fails to do so. But I am sure we all know where that is on their to do list, don't we. :Smile_hiding:

  • Cool 2

Share this post


Link to post
Share on other sites

I too am having crashing issues...

Crashes with or without Mods...

Tried the "Preferences" fix, and It crashes every other match...

Reinstalling the Game completely now.

If it crashes after that, I will try the Old Installer.

If it crashes still, it may be  Sayonara for me, it's driving me nuts!

 

Screenshot_14.png

Screenshot_8.png

Share this post


Link to post
Share on other sites
USMCGal    75
50 minutes ago, Spartacus1968 said:

I too am having crashing issues...

Crashes with or without Mods...

Tried the "Preferences" fix, and It crashes every other match...

Reinstalling the Game completely now.

If it crashes after that, I will try the Old Installer.

If it crashes still, it may be  Sayonara for me, it's driving me nuts!

 

Screenshot_14.png

Screenshot_8.png

If you are running the Game Center Client try setting the Direct X version to Version 9 and see if that gets you running again...I hope something works for you! Good luck.:Smile_honoring:

Share this post


Link to post
Share on other sites

This will never be fixed. Contact support and they will have you run some useless integrity checker, and then tell you to poke holes in your router by opening ports, even though your machine runs EVERYTHING else without problems. You may have some luck with solutions provided by well meaning users, but the crashes will return. Guaranteed. The only way to fix them is for WG to fix it, but they would rather keep churning out premiums and what not to charge more money. Priorities, right?

Share this post


Link to post
Share on other sites
8 hours ago, Noone_You_Know said:

This will never be fixed. Contact support and they will have you run some useless integrity checker, and then tell you to poke holes in your router by opening ports, even though your machine runs EVERYTHING else without problems. You may have some luck with solutions provided by well meaning users, but the crashes will return. Guaranteed. The only way to fix them is for WG to fix it, but they would rather keep churning out premiums and what not to charge more money. Priorities, right?

 

AMEN !

 

OMG...  i cant play anymore.... is no fix anywhere ..... gl

 

 

Share this post


Link to post
Share on other sites
USMCGal    75

The link to the original installer is further up in this thread if any of you are still having issues. :Smile_honoring:

Share this post


Link to post
Share on other sites

My game keeps crashing every time after my ship is sunk or the battle is over. I have tried fixing the graphics and it has only helped a little bit.

Edited by Razorback_50

Share this post


Link to post
Share on other sites
USMCGal    75
2 hours ago, Razorback_50 said:

My game keeps crashing every time after my ship is sunk or the battle is over. I have tried fixing the graphics and it has only helped a little bit.

What about your Direct X setting? Have you tried lowering that to 9? 

What I generally do is set everything to the lowest possible settings, turn shadows off ,anti aliasing, foliage etc.. Then slowly turn one thing back on then play a game. It is tedious and I do not know what you have attempted yet. Just tossing stuff out there for you to try...:Smile_honoring:

Share this post


Link to post
Share on other sites
On 10/28/2017 at 10:31 PM, USMCGal said:

If you are running the Game Center Client try setting the Direct X version to Version 9 and see if that gets you running again...I hope something works for you! Good luck.:Smile_honoring:

 I had to uninstall and completely reinstall the game.

Nothing else worked, but I'm fine for now.

Thanks

Share this post


Link to post
Share on other sites
USMCGal    75
5 minutes ago, Spartacus1968 said:

 I had to uninstall and completely reinstall the game.

Nothing else worked, but I'm fine for now.

Thanks

Thanks for the feedback! I sincerely hope you do not have to do that after every update. Glad you are back up and playing again! :Smile_honoring:

  • Cool 1

Share this post


Link to post
Share on other sites
On 10/26/2017 at 5:53 PM, xXLasre15Xx said:

Attached are the screenshots of all crashes. I've already tried running the game in safe mode. Haven't reinstalled it yet due to the time it takes. World of Warships crashes occasionally, yet not always. It is always during or immediately after loading the game, and appears to be from the fact that the game cannot sometimes find files. After running the client repair function, the issue still occurs. 

Recreation process: Open World of Warships. If bug occurs, recreation successful. If not, close and try again.

Screenshot (1).png

Screenshot (2).png

Screenshot (3).png

Screenshot (4).png

Same here, seems as if a very easy way to suck more dublooms out of my bank....... Everytime I get an update I fight with this same crap, it is neverendiung and really takes away from the fun of the game.

Share this post


Link to post
Share on other sites
xXLasre15Xx    1

Update: Using a steam account, it actually lets me into the game.... Until it crashes. 

 

The steam version seems to be suffering the same problem.

Share this post


Link to post
Share on other sites
mikemet    2

I keep crashing while loading. I've played 10,000 games with no issues until now. I'm not tech savvy at all so I may be screwed. I have no mods nor have I made any changes. I may have seen somewhere that WOW was applying a patch at 5 pm. Hope this is the issue. I really wanted to play on December 7th for obvious reasons. Good luck to all on solving their dilemmas.

Share this post


Link to post
Share on other sites
Boomslanger    0
On 10/27/2017 at 3:57 PM, xXLasre15Xx said:

1. I have no mods

 

2. I'll try using the old installer. Does anyone know where I can find it?

PLEASE, SOMEONE, HELP!! CRASHES MY COMPUTER AND NOW THE GAME CLIENT JUST CRASHES WHEN I TRY TO LOAD IT!. I SEE THAT ALMOST EVERYONE's CRASH MESSAGE HAS ' BIG WORLD' ENCOUNTErED AN ERROR AND MUST STOP..

 THIS STARTED HAPPENING FROM CLIENT 6.14 AND 6.15 IS UNPLAYABLE CLIENT7 (PUBLIC TEST) IS ALSO CRASHING. hELP AND EXCUSE THE CAPS. KEY STUCK: KITTY GOT PISSED AT ME FOR BEING GRUMPY AND SPILLED MY COFFEE... dUDE EHO TRIED TO UPLOAD INSTALLER: PLEASE TRY AGAIN, THIS LINK DOES NOT WORK. THIS CRASH THING WAS NOT THERE IN THE CLIENT BEFORE 6.14.

1

 

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×