Jump to content
Sign in to follow this  
You need to play a total of 5 battles to post in this section.
Darthvader_9

Birthday anniversary

19 comments in this topic

Recommended Posts

47
[RE]
Members
485 posts
17,832 battles

So I got the message for a T10 ship, but no container

Got the anniversary message for the flags, amount of game but no flags either

any 1 else have this issue?

  • Cool 1

Share this post


Link to post
Share on other sites
47
[RE]
Members
485 posts
17,832 battles
1 minute ago, SalvoSanta said:

i got 11 containers but can't get one for the Kurfurst, my last one.

the same

Share this post


Link to post
Share on other sites
1,490
[INTEL]
Members
6,632 posts
25,386 battles

Got a couple already in 3 battles.

Missing the one for GK.

Share this post


Link to post
Share on other sites
1,692
[TBW]
Members
6,354 posts
11,904 battles

Yoda.jpeg.0cc52fe423072c51f832c74dc882cf31.jpeg

If, glitch there is, fix it, WG will.

Edited by Sovereigndawg
  • Cool 1

Share this post


Link to post
Share on other sites
Members
22 posts
11,984 battles

I am not even trying to play my tier 10's until i get the "Special" flags from mission 1 so i can stack them with 3x xp for free xp and i played like 10 games and still no flags.

So i'm stuck playing tier 2 and 3 until they come down.:Smile_facepalm:

I've tried everything playing different ships, same ships,ships of different tiers and nada.

Share this post


Link to post
Share on other sites
845
[SSG]
Alpha Tester
3,385 posts
7,979 battles

yep message "here, have flags" after 2 wins no less, no flags -insert slow clapping here- Delayed, make it require an extra battle, get to the day and it doesn't work. 

Share this post


Link to post
Share on other sites
1,126
[ARGSY]
Beta Testers, In AlfaTesters
5,123 posts
18,640 battles

Got also mission 1 done and no reward.

Share this post


Link to post
Share on other sites
179
[LLMF]
Alpha Tester
1,226 posts

The GK seems to be bugged (based on other threads).  

 

8 minutes ago, Erebthoron said:

Got also mission 1 done and no reward.

 

I got mission 2 rewards but never got mission 1.... feature rich!

Share this post


Link to post
Share on other sites
Members
24 posts
8,381 battles

hi, 

Got the SC for my 1 T10.

I completed Mission 1 and got the 10 camos but not the flags. Annoying as was counting on those flags. 

Hey ho, guess we will see what happens

Happy Hunting

Share this post


Link to post
Share on other sites
3,183
[NOVA]
Members
11,026 posts

When are the flags being issued... I was looking forward to grinding RNBB with the free prem time+flags.

 

Guess those flags aren't coming before my prem time ends?

Share this post


Link to post
Share on other sites
7,238
[NMKJT]
Beta Testers
21,226 posts
3,871 battles

I haven't gotten any anniversary gubbins at all. It kinda sucks to feel like you're missing out on everything despite qualifying.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×