Jump to content
You need to play a total of 10 battles to post in this section.
commando_brian

2nd Anniversary mission 1/where's the flags?

19 comments in this topic

Recommended Posts

Members
157 posts
10,030 battles

Pop up showed up saying "thanks for playing 6000 games with us" or so. "You get some flags... heres a link with info etc" (links to the homepage news item about bday stuff). However got no flags. 

Share this post


Link to post
Share on other sites
22
[SWBH]
Members
271 posts
9,547 battles

same here for 3000 games no camo or flags for mission 1,ive done it twice. also restarted game still no camo or flags.

im sure they are on the problem as we type these messages in lol

Share this post


Link to post
Share on other sites
11
[SFBBW]
[SFBBW]
Members
36 posts
8,319 battles

AGAIN WG  screws thing up where my freaking FLAGS 

also just played a t10 and no freaking Super Crates,

found out Kurfest has a problem got the SC in my shimmy

Edited by TaftMan_69

Share this post


Link to post
Share on other sites
22
[SWBH]
Members
271 posts
9,547 battles
1 minute ago, TaftMan_69 said:

AGAIN WG  screws thing up where my freaking FLAGS 

 

they always fix things just give them a little while. 

Share this post


Link to post
Share on other sites
22
[SWBH]
Members
271 posts
9,547 battles

i have to say i dont feel its fair that tier 10 ship can get super containers every day and the rest of us dont get any super containers.i know players with 4 tier 10 ships,thats 4 super containers a day for a total of 16 .they are sure to get all the collections. but the rest of us might not get to complete collections due to lack of super containers.

    this make me not want to play as hard as i would to get a super container. please give those with out tier 10 ships a way to get some so we can complete out collections.

Share this post


Link to post
Share on other sites
22
[SWBH]
Members
271 posts
9,547 battles
3 minutes ago, RighteousFury42 said:

ONCE per tier10

not daily...

yeah i saw that thank you :)  got my camo but still no signal flags

 

Share this post


Link to post
Share on other sites
1,819
[V_KNG]
Beta Testers
9,268 posts
23 minutes ago, kid_next_door said:

looks like the supercontainer part has been fixed. still mission 1 for the special flags and the 10x camos is not working

 

Well I'm happy for you - however I still have nothing but the 24hr premium camo. No flags, no super containers. Now have played three tier X in my GK - won 2 of 3 - no supercontainer. 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×