Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
nothere01

[BUG] Not able to set "artilery camera" on a different hotkey

5 comments in this topic

Recommended Posts

Members
606 posts
5,429 battles
  • Issue: Not being able to set "artilery camera" on a middle mouse button, it says "Hotkey Reserved" even tho i changed the "Track Shells/Torpedoes" on a different hotkey.
  • Expected Results: I have played the game with this setting pretty much from the begining and is taking away the comfort of playing without this. It would be appreciated if it was fixed as i believe this is a bug, since i played it like this for months.
  • How to Replicate: Simply try to change "artilery camera" to a middle mouse button, several players were able to replicate this issue.
  • Cool 1

Share this post


Link to post
Share on other sites
1,579
[TASH]
Members
4,996 posts
7,925 battles

Binding it to the mouse has been an issue for a while.  Binding it to another key still works as long as that key isn't used for something either.

Share this post


Link to post
Share on other sites
85
[CYKA]
Members
847 posts
4,826 battles

Manually edit the preferences.xml

Open the file, browse the node tree: root > scriptsPreferences > check if the tag keyboardControls is created or not. below is my full keyboardControls tag

<keyboardControls>
			<CMD_SHIP_PARAMS
					keyCode="KEY_GRAVE" 
					index="0" /> <!-- display the ship status. Key [`]-->
			<CMD_QUICK_THANK_YOU
					keyCode="KEY_F4"
					index="0" /> <!-- Say Thank you -->
			<CMD_QUICK_AYE_AYE
					keyCode="KEY_F5"
					index="0" /> <!-- Say Wilco -->
			<CMD_QUICK_NO_WAY
					keyCode="KEY_F6"
					index="0" /> <!-- Say Negative -->
			<CMD_QUICK_NEED_SUPPORT
					keyCode="KEY_F7"
					index="0" /> <!-- Say Requesting support -->
			<CMD_QUICK_NEED_AIR_DEFENCE
					keyCode="KEY_F7 KEY_LCONTROL"
					index="0" /> <!-- Say Need AA support. Key [Ctrl+F7] -->
			<CMD_QUICK_NEED_VISION
					keyCode="KEY_F12"
					index="0" /> <!-- Say Need spoting data -->
			<CMD_QUICK_BACK
					keyCode="KEY_F3 KEY_LCONTROL"
					index="0" /> <!-- Say Get back. Key [Ctrl+F3] -->
			<CMD_QUICK_GOOD_GAME
					keyCode="KEY_F9"
					index="0" /> <!-- Say Good game -->
			<CMD_QUICK_CARAMBA
					keyCode="KEY_F11"
					index="0" /> <!-- Say !@#$%^ -->
  
			<!-- deleted my consumable key -->
  
			<CMD_MAIN_CALIBER
					keyCode="KEY_MOUSE5"
					index="1" /> <!-- Change to main battery without change AP or HE, Forward button on your mouse if you have one -->
			<CMD_TORPEDOES_ANGLE
					keyCode="KEY_MOUSE4"
					index="1" /> <!-- Change between wide spread and tight spread, Backward button on your mouse if you have one -->
			<CMD_ART_CAMERA
					keyCode="KEY_MIDDLEMOUSE"
					index="1" />  <!-- Your artilery camera binded with MMB -->
</keyboardControls>

 

  • Cool 1

Share this post


Link to post
Share on other sites
1,692
[TBW]
Members
6,354 posts
11,905 battles

If you can assign your mouse keys, change them to a different key. I have a gaming mouse and had the same problem. So I changed the mouse instead.

Share this post


Link to post
Share on other sites
Members
606 posts
5,429 battles
1 hour ago, leehwongxing said:

Manually edit the preferences.xml

Open the file, browse the node tree: root > scriptsPreferences > check if the tag keyboardControls is created or not. below is my full keyboardControls tag

 

thanks man, it worked

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×