Jump to content
You need to play a total of 10 battles to post in this section.
vital211

Game crashes None stop

40 comments in this topic

Recommended Posts

Members
22 posts
3,511 battles

So after getting back into the game, I have noticed that my game will crash when opening crates every time, so I decided to do a fresh install and install the game center. well, this did not help at all as the game will still crash every game even mid game or when I get back to the lobby to que for another match with my div.

 

I really want to keep playing but I can not as the crashing is way too much and i always get this same error which is attached below

 

can someone help me here? 

 

WorldOfWarships_2017-09-10_19-07-06.png

Share this post


Link to post
Share on other sites
143
[VOP]
Members
329 posts
6,760 battles

Try closing the Game Center Client and locating the folder where the Wows exe is located and run the game from that location directly.. see if that corrects the issue.

Share this post


Link to post
Share on other sites
585
[ARRGG]
Members
4,674 posts
7,503 battles

Mine was doing the same thing after the last update the advice I got here was check the hard drive space were Wows is installed because the new update requires 40GB free space and I only had 28 GB so after deleting lots of stuff got 120GB and reinstalled the game .. all was good

Share this post


Link to post
Share on other sites
Members
22 posts
3,511 battles
23 minutes ago, HMCS_Devilfish said:

Mine was doing the same thing after the last update the advice I got here was check the hard drive space were Wows is installed because the new update requires 40GB free space and I only had 28 GB so after deleting lots of stuff got 120GB and reinstalled the game .. all was good

I have 271 GB Free so that is not the problem 

 

24 minutes ago, USMCGal said:

Try closing the Game Center Client and locating the folder where the Wows exe is located and run the game from that location directly.. see if that corrects the issue.

I will try this and update the post but it was doing this before I installed the game center so I am thinking it will be the same

Edited by vital211

Share this post


Link to post
Share on other sites
Members
22 posts
3,511 battles

Ok so update setting it to run as administrator and launching it from the folder and not the launcher worked so far. i have not crashed in 5 games where it was crashing every game before. 

Share this post


Link to post
Share on other sites
143
[VOP]
Members
329 posts
6,760 battles
1 hour ago, vital211 said:

Ok so update setting it to run as administrator and launching it from the folder and not the launcher worked so far. i have not crashed in 5 games where it was crashing every game before. 

That is great I am glad you are back up and running!

  • Cool 1

Share this post


Link to post
Share on other sites
Members
22 posts
3,511 battles

Thanks for the input im glad it's working now. just hope they fix it in the next patch so I do not have to keep doing this. 

Share this post


Link to post
Share on other sites
143
[VOP]
Members
329 posts
6,760 battles

Same error as above or something else?

At what specific point does it crash this time around? i.e. at port, or when diving up , or when getting into the game.

Can you run a repair of the game files through the integrity check?

Do you have any mods enabled/installed?

I am just tossing questions out there as I do not know what you have tried or not to fix the issue.

Have you sent in a support ticket as well?

  • Cool 1

Share this post


Link to post
Share on other sites
Members
22 posts
3,511 battles
50 minutes ago, USMCGal said:

Same error as above or something else?

At what specific point does it crash this time around? i.e. at port, or when diving up , or when getting into the game.

Can you run a repair of the game files through the integrity check?

Do you have any mods enabled/installed?

I am just tossing questions out there as I do not know what you have tried or not to fix the issue.

Have you sent in a support ticket as well?

 

Same as above

Allways in game during a match. "it's ticking me off because it's usually when i am in a huge fight"

done that like 15 times and reinstalled again today. 

no mods fresh install

 

Share this post


Link to post
Share on other sites
143
[VOP]
Members
329 posts
6,760 battles

Is that with the Game Center Client off? (meaning you killed it  from the task manager)

You are doing the Run from the games .exe with Administrator permissions on the file like before?

 

Share this post


Link to post
Share on other sites
52
[V_KNG]
Members
560 posts
8,511 battles

Better yet - Earlier I was in Free Look and I couldn't get out of it and had to aim with my ship..... thought Okay my mouse is old maybe a button stuck? NOPE just now I was firing and Killed the enemy then my guns would not stop firing and the game kicked me out. Yea there is a bug in the game right now. 

Edited by Pete_Darling

Share this post


Link to post
Share on other sites
143
[VOP]
Members
329 posts
6,760 battles

Vital211: Possible Solution to the Crash -Exception_Access_Violation- Errors.

http://windowsreport.com/exception-access-violation-windows-10/

There is a Data Execution Prevention issue possibly happening here. If you follow the instructions on the page (scroll down past the stupid ad) and add warships to the Data Execution Prevention Tab in the instructions that may get the game back up and running again.

WARNING***This is the important part I felt that you should be aware of before make this change.

"Sometimes an innocent application will trigger DEP simply due to faulty coding.  We often see this on older applications or things like shareware.  It is usually not intentional and never caused a problem in the old days, but now that security is paramount, inefficient (and sometimes sloppy!) memory management can cause some serious issues.  The right answer of course is for the application vendor to rewrite the portion of the app that is triggering DEP, but that is of course not likely in the case of older applications or shareware applications.  In this case, you can exempt the application for DEP monitoring so that DEP ignores it.  As long as you trust the application in question and know it is not really doing anything malicious, exempting it from DEP should not be a problem. Here is what the GUI looks like:"

This was taken from this pages article explaining DEP and the reasons behind the use or not use of it...For your information.

 https://blogs.technet.microsoft.com/askperf/2008/06/17/to-dep-or-not-to-dep/

 I would NOT add the Game Center Client to DEP.... I would however try to add the Wows.exe to it to see if that fixes the exception issue you are getting. I and others feel that the Game Center Client is too buggy at the moment to allow the client control of your pc would probably not be a good thing.

 

**Question: Does your video card support Direct x11?

Just curious on this as I found a very old thread where a WG support person had someone update their video card to fix a similar crash problem.

Link here:

https://forum.worldofwarships.eu/topic/18161-unhandled-exception-access-violation/

 

Peter_Darling- Add your bug to the Feedback thread for this last patch. I know others have complained about your issue. I know someone whose guns would not fire for quite a while until eventually they came back. Perhaps pay attention to what you were doing when it did happen. They(the ever elusive support persons) want to be able to replicate the issue if possible so list details if you can...

Edited by USMCGal

Share this post


Link to post
Share on other sites
52
[V_KNG]
Members
560 posts
8,511 battles
3 hours ago, USMCGal said:

 

Peter_Darling- Add your bug to the Feedback thread for this last patch. I know others have complained about your issue. I know someone whose guns would not fire for quite a while until eventually they came back. Perhaps pay attention to what you were doing when it did happen. They(the ever elusive support persons) want to be able to replicate the issue if possible so list details if you can...

 

Will do 

Share this post


Link to post
Share on other sites
Members
2 posts
5,600 battles

Ok, I have been having a lot of issues with WOWS as well.  Every game I would start, it seemed to crash.

I noticed during one crash, that I lost sound.  But, the Co-Op game played all the way to the end.

I turned off all the sounds (ie. Voices, music, gunfire, everything), and I managed to play 2 full Random games.

I turned the sound on again, while starting up in "High" mode, not "Ultra", and the same thing just happened.

Going to try and see if I can update some sound drivers, but it looks like the sounds are causing my problems.

Share this post


Link to post
Share on other sites
Members
22 posts
3,511 battles

nothing has worked for me. it stopped crashing for almost 2 days but now its crashing every 15 secs so i'm done with this game for now. 

Edited by vital211

Share this post


Link to post
Share on other sites
Members
109 posts
2,701 battles

OUCH.....okayyyyyy...

     I haven't played since this last upgrade.

.........and now I'm scared to start a game (cause I've been having crashes since way back),,,lol

Share this post


Link to post
Share on other sites
Members
22 posts
3,511 battles

ok so i think i have a fix

 

i uninstalled graphics cards and reinstalled then i went into game options and switched it from dir x 11 to 9 i only crash like once every 4-5 games now

 

Share this post


Link to post
Share on other sites
143
[VOP]
Members
329 posts
6,760 battles

Run the dxdiag command in a search window and see what your graphics cards Direct X is....If that was your issue then the other thread about upgrading the video card is probably what is needed. So it can run the more current Direct X....

Maybe try running at low graphics within the game to see if this helps eliminate the crashes altogether...I had issues when running at high settings so I have been running at low for a while now.. except when they reset stuff...

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×