Jump to content

Search the Community

Showing results for tags 'ps4'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • World of Warships - News and Information
    • News And Announcements
    • Updates and PTS
    • Developer's Corner
    • Community Volunteer Programs
  • Feedback and Support
    • Game Support and Bug Reporting
    • Player Feature and Gameplay Suggestions
    • Game Guides and Tutorials
  • General WoWs Discussion
    • General Game Discussion
    • Discussions about Warships
    • Player Modifications
  • Off Topic
    • Historical Discussions and Studies
    • Off-Topic
  • International Forums
    • Foro en Español
    • Fórum Brasileiro

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Discord


Twitter


Website URL


Instagram


YouTube


Twitch


Skype


Location


Interests

Found 3 results

  1. Can I send a recruit link to a friend who will want to play on the PS4 and both get the mutual rewards?
  2. I played this game on pc back when it was in ob and first went live. I was happy to see it come to consoles as I do like playing it. However, this random autosteering that the ships do is frustrating. Especially with destroyers which the A.I. seems to think should be land vessals rather than ships, i.e. they like to steer directly into islands. Having to fight the ship between two islands while trying to line up shots is a major pain in the [edited]. Can this be fixed? BTW, I have already turned of steering assist.
  3. I just downloaded the game on my PS4, and 4 games in and I haven't been able to fie a single shot no matter what I try. I've been scouring the internet to see what was wrong, to make sure it wasn't me doing something wrong, and there's not really much in game to go on. As far as I can tell, I'm doing everything right on my end, which is what led me here. Either A. this is a bug, or B. there is some mechanic not explained in game that is keeping my guns from firing, and others since I've seen the same complaint around the internet, just not here, and searching for a PS4 or console forum for WoWS also leads here. Since there does't seem to be any real info on what's going on (that I can find), I'm going to post this here and hope for some answers
×