Jump to content

SgtCC

Members
  • Content Сount

    11
  • Joined

  • Last visited

  • Battles

    2697

Community Reputation

1 Neutral

About SgtCC

  • Rank
    Seaman
  • Insignia
  1. I have tried everything, nothing is working. I guess mac os users at crapout of luck. I really liked the game. Have too many premium and high level ships to start again.
  2. Have done everything any of you have suggested. Still get the error message. Clear that all Mac users are on their own. Each attempt at an update is worse. What I find interesting is the silence, the lack of any sense of responsibility, corporate or otherwise. The money, when spent, goes to wargame, yet there is no interest on insisting on follow up or prompt support. For all those Mac users who bought services, ships or premium are being deprived of their products and or the use of service that they paid for. WoTs works fine at the moment, which begs the question, why the difference? i TrueType enjoyed WoWs, and the chats, clans and game play. Still waiting for a fix, but if none is forthcoming, I shall miss the game.
  3. No answers here, even though support says all Mac question will be handled here. Have used all the fixes and nothing works, including app cleaner. WoTs works fine after update. Where is the Mac support?
  4. Are we going to get any answers? Seems no answers are going to come for Mac users.
  5. Have done all of these fixes, with no results. I get to the port screen which is black. Music playing, can't see the ship, none of the controls work. Slow moving when trying to exit. Have used App Cleaner...downloaded new version at least three times. Don't see a solution here that works. Mac Mini (2011) i5 processor 8 G ram Os 10.12.6 . The previous versions worked fine. Really disappointed at thi time, loosing premium time since this update. Does anybody know what's going on? Any idea when they are fixing this? Actually enjoyed WoW. HELP. Have used the launcher settings to check integrity, still will not work.
  6. Have done all of these fixes, with no results. I get to the port screen which is black. Music playing, can't see the ship, none of the controls work. Slow moving when trying to exit. Have used App Cleaner...downloaded new version at least three times. Don't see a solution here that works. Mac Mini (2011) i5 processor 8 G ram Os 10.12.6 . The previous versions worked fine. Really disappointed at thi time, loosing premium time since this update. Does anybody know what's going on? Any idea when they are fixing this? Actually enjoyed WoW. HELP
  7. With the update basically booting Mac users off the game, are we going to get some fixes for our premium days lost? Is there going to be a fix soon? Support has not been helpful when it comes to Mac problems with updates. The game is great, would like to get back to it.
  8. I am having the same problem...don't see the fix. Have not been able to use since update. Is there a solution that makes sense available.
×